How to prevent audio output to automatically switch to headphone port?

I have a headphone/mic audio jack. I want to plug in an audio source into this jack and play the audio through the speakers. I know I can listen to an input source. The problem is when I plug in the cable, the audio output will default to the jack. My output device is a speaker/headphone and I set up the jack as a default input device. There is no option in the speaker/headphone device that I can find to explicitly set it to speaker.

Help?
Hi,

You may make the headphone default, so that Windows will use them only when they are plugged in.
 
Method  1:
Check with volume settings.
a. Right click on the speaker icon in taskbar and select volume control options.
b. Put a check mark on "All devices currently playing sound".
c. Make sure you have "The default communication device unchecked".
d. Place a check mark on both speakers and headphones.
Let us know what happens when you play.
 
 
Method 2:
You may check if the Headphones are enabled as a playback device. To do this, please see the steps below:
a) Click the Start and then type Sound in the Start Search Box.
b) Select Change Sound Card Settings in the Start Menu Options.
c) Next, under the Playback Tab, right click and selectShow Hidden Devices and Show Disconnected Devices if available.
d) Select Headphones and enable

Reference link:
Tips for fixing common sound problems

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi my problem is the opposite of what you think it is. I want the speakers to be default when I plug in a cable. I do not want it to default to headphones. 

What I want to do is set the speakers as the default, and use the jack as an input. Why is this so hard?

Further more, I only have one output device: headphone/speaker. I cannot set them individually. I have also tried enabling the mic jack device under input and disabling all other input devices. Still nothing.


I've tried updating the drivers on the sound devices under Device Manager. No new drivers.

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

​Hi,

You may change the default to external speaker from the Control Panel or from Notification area.

a. Right Click on speaker icon and select playback devices. A new window titled soundshould open up.
b. Right click on the blank area place a checkmark on “Select Disabled Devices”and “Select Disconnected Devices”.
c. Select your speaker, right-click on it and select enableto make sure that it is enabled.
d. Select the speaker and click on “Set Default”button to set it as default device.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

 
 

Question Info


Last updated October 23, 2020 Views 9,790 Applies to: