Game Mode cause stuttering lag / bad movement keys registering

I have a new crucial thing to add to my 2nd topic which is also locked.

TL;DR How to fix it:

You need to:

-set explorer.exe priority to above normal or high (depends on a game) [don't close explorer.exe during gaming with Game Mode enabled)

and also (at least in Forza Horizon 3 and probably other UWP apps):

- go to taskmgr and in Service Host: Remote Procedure Call>details>set priority>above normal

- sometimes you also need to lower your details

- don't change pre-rendered frames from default 3

- keep your frame lock and V-Sync on

- sometimes you also need to lock your FPS to 30 (e.g. on higher details/resolution) then you might want to change default pre-rendered frames settings

- (and a new thing) If all above fail, set your game priority to idle

- In FH3, don't set the game to 16/44 (the best is 16/48)

You might want to install Process Lasso to keep your process priority.

...

How the problem looks like?

You try to turn using arrows e.g. while driving, and the key is registered with delay. The same for accelerate key bound to some letter.

Or you try to move, but you can't, or it is difficult. Key registering is not constant, and instant.

When the problem occurs?

When the game mode is run probably on units with slow CPUs.

It was fixed by setting explorer.exe to high/above normal and one of svhost.exe to above normal.

The problem can be also triggered by closing explorer.exe during the game, while with game mode turned off, explorer could be closed without causing the problem.

The other thing triggering the issue was changing game application priority to higher than "normal" (even with explorer set to "high").

I encountered the problem in various games like: BF V beta, FH3, FH4 demo.

Actually it's also shame that when we close explorer.exe after UWP app launch (e.g. from relevant command in CMD.exe), which fixes FH3/4 crashes for some people, OS becomes unresponsible. There is only black screen on game exit, and we cannot launch explorer.exe manually then. We need to log off via ALT+CTRL+DEL (good that at least that thing works).

I also don't quite like the thing in 1809, that game mode was deleted from game bar. Now it needs to be disabled/enable in Windows Settings>Gaming>Game Mode, instead of Win+G in the game, and pressing button.

If you don't have to, please don't close that topic.
 

Discussion Info


Last updated June 30, 2020 Views 745 Applies to: