File and Print Sharing resource (MyIP to share) is online but isn't responding to connection attempts.

  Hello,

I have been receiving an error when trying to reach my shared directory from my PC that states the following:

"File and Print Sharing resource (MyIP to share) is online but isn't responding to connection attempts."  I've been sharing this directory for a long time and it suddenly just stopped working. 

I'm finding that I can access shared directories from other servers but I cannot share directories from my PC.  I have file and print sharing turned on and I've used Windows Network Diagnostics for troubleshooting which is where I got the error "File and Print Sharing resource (MyIP to share) is online but isn't responding to connection attempts." 

Thanks,

David

|
Homegroup has been discontinued with the release of Windows 10 1803.Your best option is to use a basic peer to peer workgroup network with Public File Sharing and Permissions. Learn more:

https://www.kapilarya.com/homegroup-alternative...

https://www.groovypost.com/howto/connect-netowr...

and

https://www.groovypost.com/howto/share-files-st...

https://www.groovypost.com/howto/change-network...

https://www.groovypost.com/howto/share-printer-...

Open Start > Settings > Network & Internet > Status
Scroll to the bottom
Click Network and Sharing Center

Click Change advanced sharing settings
Expand All Networks
Under Password protected sharing

Switch between 'Turn on password protected sharing and Turn off password protected sharing'

Then choose 'Turn off password protected sharing'

Then click 'Save changes'

Also:

Press Windows key + R
Type: optionalfeatures.exe
Hit Enter

Scroll down to SMB 1.0/CIFS File Sharing Support
Tick the SMB 1.0/CIFS Client
Untick SMB 1.0/CIFS Automatic Removal and
Untick SMB 1.0/CIFS Server


Click OK
Restart if prompted.


Additional troubleshooting steps you can attempt:
- shut all computer and network gear down.
- Turn off IPv6
- Try browsing to some of the computers manually, press Windows key + R, type: \\computername, hit Enter
- Press Windows key + R
Type: services.msc
Hit Enter

1. Start the "Function Discovery Provider Host" and "Function Discovery Resource Publication" services, and then set them toAutomatic (Delayed Start).
2. When you open Explorer Network, enable network discovery when you are prompted.

Press Windows key + X > computer management-->shared folders--> choose the shared folder, right click it then click Properties > Share Permissions -->protection that everyone can read and execute, see folder contents and read permissions.

Add the machine to your Windows HOSTS file.
https://www.groovypost.com/howto/edit-hosts-fil...

See this thread for further tips:
https://answers.microsoft.com/en-us/windows/for...
Best regards,
Andre Da Costa
Independent Advisor for Directly

Was this reply helpful?

Yes
No

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated September 15, 2021 Views 4,339 Applies to: