Fatal error during installation causes .NET Framework 4 to fail error code 66A

**added error code to title**

original title: I cannot remove or repair .NET Framework 4 because:  Fatal error during installation.  What should I do?

Windows Update can't install the latest update for .NET Framework 4; it's tried automatically many times and failed, and when I try to update it manually it hangs up and does nothing.

 

Troubleshooting led me to a problem with corrupted files on my machine, with the solution being to repair Microsoft .NET Framework 4 via "Programs and Features' (Windows 7 Professional edition, 64-bit).

 

When I try to repair or remove Microsoft .NET Framework 4, either process fails after only a moment.  The result is a message saying that the repair or removal did not succeed because:  Fatal error during installation.

 

I've rebooted and shut down all applications except Norton 360 and tried again, but I can't remove or repair the .NET Framework 4.

 

The log of the error reads thusly:

---


OS Version = 6.1.7601, Platform 2, Service Pack 1
 OS Description = Windows 7 - x64 Service Pack 1

 CommandLine = "C:\Windows\Microsoft.NET\Framework64\v4.0.30319\SetupCache\Client\Setup.exe" /repair /x86 /x64 /parameterfolder Client
 TimeZone = Central Daylight Time
 Initial LCID = 1033

Using Simultaneous Download and Install mechanism
Operation: Repairing

 Package Name = Microsoft .NET Framework 4 Client Profile Setup
 Package Version = 4.0.30319

 User Experience Data Collection Policy: Disabled

Operation updated to: Uninstalling

ServiceControl operation succeeded!

MSI (C:\Windows\Microsoft.NET\Framework64\v4.0.30319\SetupCache\Client\netfx_Core_x64.msi) Uninstall failed. Msi Log: Microsoft .NET Framework 4 Client Profile Setup_20120427_143222587-MSI_netfx_Core_x64.msi.txt
Final Result: Installation failed with error code: (0x80070643), "Fatal error during installation. " (Elapsed time: 0 00:00:09).

---

 

I can post a much longer version with all details if it's helpful.  Can anyone offer advice?

 

Thanks!

 

PS - Microsoft Fix It tool does not find any errors so it won't resolve the issue and allow me to repair the .NET Framework.

 

Question Info


Last updated November 14, 2018 Views 58,878 Applies to:
Answer

Reinstalling Windows 7 with the format disk option from the DVD solved the problem for me.  After that, the .NET framework updated successfully (once it had gotten updated back up to the point to try it).  I no longer have any failed Windows Update items.

The clean install was a nice refresher anyway, so all in all it wasn't the end of the world.  But if you're going to go that route, make sure you back up ALL of your data and can reinstall all programs from download or DVD, before you do the format.

15 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.