Windows 7 support has ended

Get Windows 10 to continue receiving support.

Upgrade now

Error: The boot configuration data store could not be opened. Access is denied

Original title: Can't open BCDedit!

Hello All!

For some reason BCDedit won't open for me now. I've used it before in Windows Vista to edit OS description names on my dual-boot (XP-Vista) system, but now when I go into the command prompt and type in BCDedit it returns "The boot configuration data store could not be opened. Access is denied" I'm logged in as administrator (as I was the previous times that I had used it) but all of a sudden it won't open now. Does  anyone have any insights on this one. I was hoping to use BCDedit in my new version of Windows 7 as well.

Thanks Much,

Mark D'Aloia

***Post moved by the moderator to the appropriate forum category.***

 

Question Info


Last updated May 20, 2020 Views 190,568 Applies to:
Answer
Answer

HiMark D'Aloia,

 

The boot configuration data store could not be opened. Access is denied. This issue can be fixed by running the BCDedit command as an administrator.

 

Follow this step to do the same:

 

a.    Click Start,and then type cmd in the Start Search box.

b.    Right-click cmd in the Programs list, and then click Run as administrator. If you are prompted for an administrator password or confirmation, type your password or click Continue. 

c.    At the command prompt, the following line, and then press ENTER:

bcdedit /set {current} Description "name you want"and press Enter.

d.    In the elevated command prompt, typebcdedit and press Enter.

NOTE:This will let you see and verify the new name of the {current} operating system.

e.    Close the elevated command prompt.

 

When you restart the computer next, you will see the new name listed for the operating system.

 

Refer these links for more information:

Boot Configuration Data

http://technet.microsoft.com/en-us/library/cc721886%28WS.10%29.aspx

 

BCDEdit Command-Line Options

http://technet.microsoft.com/en-us/library/cc709667%28WS.10%29.aspx

 

If the above method does not help, enable the Default Administrator account and check.

To enable the default administrator account, you would have to login to an account having administrative privileges and follow the steps mentioned below:

 

a.    Click Start, and select Control Panel.

b.    Click the  View by drop down menu, and select Large items.

c.    Select Administrative Tools.

d.    Open Computer Management.

e.    In the left-pane of Computer Management, double-click  Local Users and Groups.

f.     Click the  Users folder.

g.    Right-click Administrator account and select Properties.
The Administrator Properties window appears. 

h.    On the  General tab, clear the Account is Disabled check box.

i.     Exit the Computer Management console.

 

Refer the link below for more information:

 

Enable and Disable the Built-in Administrator Account

http://technet.microsoft.com/en-us/library/dd744293%28WS.10%29.aspx

 

 

Regards,

Divya R – Microsoft Support.

Visit our Microsoft Answers Feedback Forum and let us know what you think.

41 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.