Error: 8004E00F when trying to access COM+ Applications in Component Services

my 3 others HP notebooks with Windows 10 Pro. All installed OK and no issues.

Once we applied the latest Windows updates, I am no longer able to access COM+ Applications in Component Services - Error code 8004E00F - COM+ was unable to talk to the MDTC.  DTC service is running as Network Service.

After update 1809  on Windows 10 Pro  getting COM+ error!!!

***Modified title from: COM+ error after 1809 update (Wndows 10 Pro on HP notebook)***

 

Question Info


Last updated November 19, 2019 Views 3,683 Applies to:

Hi,

Thank you for writing to Microsoft Community Forums.

This error could be because of missing or damaged MS DTC or the Network Service account does not have sufficient permissions.

We can try the steps mentioned below and check if that helps in resolving the issue:

Method 1: Re-create the MS DTC log

Re-create the MS DTC log, and then restart the service. To do this, follow these steps:

  1. Type Command Prompt in the search bar on the taskbar.

  2. Right click on Command Prompt icon and click on Run as administrator.

  3. At the Command Prompt, type the following command, and then press ENTER: msdtc –resetlog

    Warning The msdtc -resetlog command can cause data corruption if it is used incorrectly. Make sure that you do not have any pending transactions when you run this command.

  4. Type the following command, and then press ENTER: net start msdtc.

If Method 1 didn’t help, please follow Method 2.

Method 2: Re-registering the service

Note:  Important this section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs.

Follow the steps to take backup of registry.  

  1. Press the Windows logo key + R to open the Run dialog box.

  2. Type regedit in the Run dialog box, then press Enter.

  3. Navigate to the location: HKEY_LOCAL_MACHINE\Software\Microsoft\MSDTC

  4. Right click on TurnOffRpcSecurity and select modify. Change the value to 1.

  5. Now, in Run box, type services.msc.

  6. Look for Distributed Transaction Coordinator and stop the service.

  7. Double click on the service and click on Log On tab.

  8. Now type NT Authority\NetworkService under This account.

  9. Leave the password section blank.

  10. Click on Apply and OK.

  11. Start the service.

  12. Restart the computer.

Hope it helps.

Please reply with the status of the issue, we will be glad to help you further.

Nikhar Khare

Microsoft Community - Moderator

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

So sad, but these actions did not change anything....

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

When you are running Windows 10 on HP Systems, it is very likely that the running HP services cause MSDTC to become unavailable.

Try stopping and deactivating all services that start with "HP ...", restart the Distributed Transaction Coordinator Service, and try again.

9 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

HP Hotkey UWP Service - that's a reason!

Need's to stop this HP bloatware .

4 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.