Error 0x800F0A12 when attempting to install Windows 7 Service Pack 1.

This is not so much a question as a potential answer for the edification of others regarding this error 0x800F0A12 that I got several times when trying to install Windows 7 Service Pack 1. Maybe this can help someone else with the same or similar problem.

In my case, the error was being caused by the fact that I have Windows 7 Professional installed on a Hybrid GPT/MBR disk. Windows 7 32-bit likes an MBR partition and my other OS prefers a GPT partition for maximum disk performance. The other OS is not important to the error message at hand, so no need to mention it here.

Additionally, I was using a third-party boot manager with the active partition being the partition with another OS that runs on a GPT partition. Apparently, the installer for Windows 7 Service Pack 1 looks to the active partition for the boot files that it needs to update.

If the Windows 7 partition is not the active partition the updater does not know where to find the files it needs to update and generates error 0x800F0A12. There was and is no System Reserved partition on my hard disk, either.

The problem was solved immediately when I set the Windows 7 partition as the active partition. After doing that, installation of Service Pack 1 went and completed without a hitch.

Here is what I did. I cannot guarantee that this will work for you but it did for me.


Before running Service Pack 1 installation, check to be sure that your Windows partition is marked as the active partition. You should do this from within Windows 7. I used two programs to do this and to change it back. If it already is the active partition what I did and wrote below will not help you.


First, I ran Disk Management from within the Computer Management console. I then right-clicked the Windows partition and marked it active. I saved changes and exited the Computer Management Console


Then, I ran the Windows 7 x86 Service Pack 1 installation from a DVD that I created from the ISO file supplied by Microsoft. I see no reason why Windows Update will not work as well, but if it doesn't, download the ISO directly from Microsoft.


You will need to Validate your Windows 7 installation to download the file. Do not risk getting it from somewhere else or you could make things worse for your system.


After the system restarts and finishes the update and configuration, run DISKPART from the Command Prompt as an Administrative or as the Administrator user and go through the steps to mark the partition from which your third-party boot manager runs as active (if that is your configuration as it is with my system). You will not be able to do this from within the Computer Management Console again so DISKPART is what you need.


Finally, after working with Microsoft's DISKPART, restart your system again and everything should be working as it should. If not, you might need to reinstall or reactivate your boot manager again.


Note: If you messed up your hard disk by running any other commands to fix the MBR or to fix boot code for Windows 7 you may have further problems that this information cannot help.


You don't need to run fixmbr, bootsect, bootfix, run repair from the DVD,etc., in instances like that I mentioned above, for this problem if you have a hybrid, single disk, or a single disk with multiple operating systems.

Just marking the Windows partition as 'active' made it work flawlessly because the Service Pack 1 installer looks to the active partition for some of the files that need to be updated. When it does not find them on the expected active partition it throws the exception and generates error 0x800f0a12.

You can either use DISKPART to do both changes or use the Computer Management Console to mark the Windows partition active and DISKPART to mark the original partition active that was active before the change.

Using fixmbr, bootsect, bootfix, or the like can actually make things worse if you are not careful. It most likely is not even necessary to run any of these. the easiest way to find out is to check which partition is actually marked 'active' using the Computer Management Console's Disk Management snap-in. If it is not and you have been getting the 0x800f0a12 error, use Disk Management to mark the Windows partition as active and the installation should run without a hitch.

Just remember to change it back to what it was so be careful to make a note of which partition was actually active before you changed it and use DISKPART to change it back so you can boot the other systems from a single disk--if that is your configuration as it was with mine.

If you do not have a hybrid GPT/MBR drive or multiple operating systems on a single drive, this information I posted above may not pertain to you. On the other hand, it may also help others with a similar situation if they are running Windows 7 on a Mac, as these actually also use a single, hybrid GPT/MBR drive, as can be done with varying flavors of BSD and OpenDarwin.

The same can also be the case with a drive that has been GParted. GPart and related utilities also can partition a hybrid GPT/MBR drive and I dare say that some have done just that and may not have been aware that they did it. Others are aware, I am sure, but are not sure what to do with Service Pack 1 when it fails to install because of it.

My solution is the simplest and least likely to render your boot manager inoperable. It also is the easiest thing to check when getting the above error. If such is not the case with your configuration, it is likely that one of the other problems mentioned on the Microsoft site may be at fault and they have the solutions for those problems.

But, as with all things, "your mileage may vary."

1 person found this reply helpful


Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.


Question Info

Last updated February 17, 2021 Views 32,962 Applies to: