DWM.EXE High CPU (One Core) On Target System after Remote Desktop Disconnect on Windows 10 x64 1903 (Fully Patched)

*** PROBLEM RESOLVED BY KB4522355 RELEASED OCTOBER 24TH 2019. ***

Two systems,

  • Intel NUC with Iris Plus Graphics 655 running latest drivers 26.20.100.6890 
  • the other with Intel HD Graphics 2500 running latest drivers 5.33.48.5069 

On completion of a remote desktop session, the target system shows high CPU utilisation (one core running at 100%) for DWM.EXE - the newer machine (Intel Iris Plus 655) will eventually crash several hours later - I suspect a memory leak such as the previous one affecting QuickSync.

If I change the drivers to "Microsoft Basic Display Adapter" then things return to normal re: DWM.EXE. It's not a long term fix as one of the machines is my Media Centre PC and I lose audio output on it, the other is a headless Plex server and I lose "Quick Sync" hardware transcoding.

Anyone else seeing this ?  If so after a bit of digging I've identified a short term workaround.

I believe there is a problem with the Microsoft RDP code in 1903 (an area which seems to have had a major internal overhaul), and I document a successful workaround. 

For clarity,

  • the behavior started with 1903
  • one system is an Intel NUC NUC8I7BEH PC with 16Gb Corsair Vengeance Memory and an Intel 760p 256Gb SSD; the other is a Chillblast Fusion Vacuum PC based on a P8H77-M motherboard. However other machines with nVidia GPU's are also affected, so this is NOT an Intel problem.
  • my testing consists of using a third machine running Windows 10 x64 1903 (fully patched) to run the Remote Desktop client software. The "targets" I refer to are the two machines I mention acting as RDP Host machines. Both demonstrate the high CPU DWM.EXE after taking them over and then disconnecting (the NUC has an 8 core CPU so shows 12.5% CPU) and the other machine based on an Intel P8H77-M motherboard.

It seems Microsoft has done significant engineering to Remote Desktop in Windows 10 1903 and I now believe a significant bug exists in the Microsoft code.

In the first article a Microsoft employee mentions

<--------------------->

There’s a known issue with some of the old display drivers.  <I believe the issue I am facing is related to this area>

Display drivers report some of their capabilities upon load. In previous Windows versions this reported data wasn’t used or verified. Because of that, some of the old versions of the legacy display driver may report invalid data and it would be ignored. Starting with Windows 10 1903 RDP uses this data to initialize the session. 

The best option is to install an updated display driver from the hardware manufacturer. If the new version is not available, you can workaround this by disabling the problematic driver in the device manager.

Our team has identified the issue and we are currently verifying the fix that will dynamically switch to the software renderer if the problematic driver is detected.

I will this thread when the fix will be included to the Windows Insider release.

<---------------------->

Further testing in my environment has shown that machines without Intel integrated graphics are also showing the problem.

In the second article it mentions a change to the RDP driver area

<--------------------->

XDDM-based remote display driver: Starting with this release the Remote Desktop Services uses a Windows Display Driver Model (WDDM) based Indirect Display Driver (IDD) for a single session remote desktop. The support for Windows 2000 Display Driver Model (XDDM) based remote display drivers will be removed in a future release. Independent Software Vendors that use XDDM-based remote display driver should plan a migration to the WDDM driver model. For more information on implementing remote indirect display driver ISVs can reach out to *** Email address is removed for privacy ***.

<--------------------->

As a workaround on all of my affected machines I have used Group Policy Editor to set

Local Computer Policy

 Computer Configuration

  Administrative Templates

   Windows Components

    Remote Desktop Service

     Remote Desktop Session Host

      Remote Session Environment

       Use WDDM graphics display driver for Remote Desktop Connections

to DISABLED

This forces RDP to use the old (and now deprecated XDDM drivers)

After rebooting, behaviour returns to normal and after disconnecting from an RDP session the RDP host (target machine) no longer shows DWM.EXE consuming CPU.

This isn't a long term fix (to rely on a deprecated feature). I also don't understand why only a limited number of users are affected, but for now, I'm up and running again, and hoping for a Microsoft fix.

 

Discussion Info


Last updated December 10, 2019 Views 8,051 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Wow, thank you for saving us. I have a Dell Vostro 3670 i5 Windows build 1903.  I have spent the entire day traveling 20 minutes back and forth between sites to restart the computer.  I thought my CPU was overheating and I was in the process of monitoring it when the computer again locked up.  Thank you.

Same here on my W10 1903 Guest VM running on 2016 Hyper-V Host.

DWM.exe pegs one CPU core after RDP session disconnects.

Seems the suggested workaround didn't work for one of my VM's. It keeps spiking the CPU when i disconnect from a RDP session.

Strange thing is that on my other VM it did work...

any other workarounds?

thx for fix! 

Thank you very much. The problem was solved by setting "Use WDDM graphics display driver for Remote Desktop Connections" to disabled

I have a Hyper-V Virtual Machine which runs 1903 x64. When the VM starts for the first time, I can connect to it via Hyper-V manager or RDP. However, if I disconnected the RDP session, I can see (from Hyper-V manager ) the VM CPU usage jumps to 100% immediately and I will not be able to connect to it via RDP nor Hyper-V manager. I had to power the VM off.

It is interesting that if I log off RDP session, this problem does not occur.

After disabling WDDM, the problem went away.

 

Same problem, Windows 10 1903 VMs.  If you RDP in, click X to disconnect, the VM becomes unresponsive until you use local group policy to disable WDDM, then reboot and the issue is resolved.

vSphere 6.5 Update 3, VMware Tools 10.3.10, 11, 11.01 doesn't help either

I have just installed KB4522355 after reading the changelog @ ghacks, which states:

Fixed a high CPU usage issue in the Desktop Window Manager that occurred when disconnected Remote Desktop Protocol sessions.

and I can at least on my end confirm that my W10 x64 vm running on proxmox 6.0-9 after disabling the workaround policy and rebooting it no longer exhibits the high cpu usage after disconnecting rdp session. I'm looking at sub 10% usage in proxmox webui with the apps I run on it after exiting rdp.

I can confirm, this issue is resolved for me with today's Windows 10 1903 Cumulative Update KB4522355, 18362.449.
I can confirm that KB4522355 (released 24 October 2019) appears to address this issue.  Any workarounds (group policy and or scheduled task) can be removed.

Not huge as previous days but problem, for me, still persist in minimal percentage (20%) as you can see from my screenshot:

Rebooting and re-enabling "no WDDM" policy result as here:

so, problem, for me, isn't fully solved. Are you sure that your remote session are quiet as intended?

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.