DWM.EXE High CPU (One Core) On Target System after Remote Desktop Disconnect on Windows 10 x64 1903 (Fully Patched)

*** PROBLEM RESOLVED BY KB4522355 RELEASED OCTOBER 24TH 2019. ***

Two systems,

  • Intel NUC with Iris Plus Graphics 655 running latest drivers 26.20.100.6890 
  • the other with Intel HD Graphics 2500 running latest drivers 5.33.48.5069 

On completion of a remote desktop session, the target system shows high CPU utilisation (one core running at 100%) for DWM.EXE - the newer machine (Intel Iris Plus 655) will eventually crash several hours later - I suspect a memory leak such as the previous one affecting QuickSync.

If I change the drivers to "Microsoft Basic Display Adapter" then things return to normal re: DWM.EXE. It's not a long term fix as one of the machines is my Media Centre PC and I lose audio output on it, the other is a headless Plex server and I lose "Quick Sync" hardware transcoding.

Anyone else seeing this ?  If so after a bit of digging I've identified a short term workaround.

I believe there is a problem with the Microsoft RDP code in 1903 (an area which seems to have had a major internal overhaul), and I document a successful workaround. 

For clarity,

  • the behavior started with 1903
  • one system is an Intel NUC NUC8I7BEH PC with 16Gb Corsair Vengeance Memory and an Intel 760p 256Gb SSD; the other is a Chillblast Fusion Vacuum PC based on a P8H77-M motherboard. However other machines with nVidia GPU's are also affected, so this is NOT an Intel problem.
  • my testing consists of using a third machine running Windows 10 x64 1903 (fully patched) to run the Remote Desktop client software. The "targets" I refer to are the two machines I mention acting as RDP Host machines. Both demonstrate the high CPU DWM.EXE after taking them over and then disconnecting (the NUC has an 8 core CPU so shows 12.5% CPU) and the other machine based on an Intel P8H77-M motherboard.

It seems Microsoft has done significant engineering to Remote Desktop in Windows 10 1903 and I now believe a significant bug exists in the Microsoft code.

In the first article a Microsoft employee mentions

<--------------------->

There’s a known issue with some of the old display drivers.  <I believe the issue I am facing is related to this area>

Display drivers report some of their capabilities upon load. In previous Windows versions this reported data wasn’t used or verified. Because of that, some of the old versions of the legacy display driver may report invalid data and it would be ignored. Starting with Windows 10 1903 RDP uses this data to initialize the session. 

The best option is to install an updated display driver from the hardware manufacturer. If the new version is not available, you can workaround this by disabling the problematic driver in the device manager.

Our team has identified the issue and we are currently verifying the fix that will dynamically switch to the software renderer if the problematic driver is detected.

I will this thread when the fix will be included to the Windows Insider release.

<---------------------->

Further testing in my environment has shown that machines without Intel integrated graphics are also showing the problem.

In the second article it mentions a change to the RDP driver area

<--------------------->

XDDM-based remote display driver: Starting with this release the Remote Desktop Services uses a Windows Display Driver Model (WDDM) based Indirect Display Driver (IDD) for a single session remote desktop. The support for Windows 2000 Display Driver Model (XDDM) based remote display drivers will be removed in a future release. Independent Software Vendors that use XDDM-based remote display driver should plan a migration to the WDDM driver model. For more information on implementing remote indirect display driver ISVs can reach out to *** Email address is removed for privacy ***.

<--------------------->

As a workaround on all of my affected machines I have used Group Policy Editor to set

Local Computer Policy

 Computer Configuration

  Administrative Templates

   Windows Components

    Remote Desktop Service

     Remote Desktop Session Host

      Remote Session Environment

       Use WDDM graphics display driver for Remote Desktop Connections

to DISABLED

This forces RDP to use the old (and now deprecated XDDM drivers)

After rebooting, behaviour returns to normal and after disconnecting from an RDP session the RDP host (target machine) no longer shows DWM.EXE consuming CPU.

This isn't a long term fix (to rely on a deprecated feature). I also don't understand why only a limited number of users are affected, but for now, I'm up and running again, and hoping for a Microsoft fix.

 

Discussion Info


Last updated June 3, 2020 Views 14,606 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

I have this problem too.  I just build a dedicated headless Plex server with Windows 10 Pro 64-bit.  I've noticed that every time I RDP into it, the CPU usage and temperature is higher than I like.  It instantly drops after the connection is made.  I will try your fix and report back.
This fixed my issue.  Thank you so much!
My Windows 1903 system running on VirtualBox started exhibiting this behavior after the end of July cumulative update. Quite annoying! Applying the group policy editor change fixed this for me. Thanks so much for providing!
Having the same issue. Upgraded some Windows 10 1809 VMs on a Hyper-V host (Server 2016) to Windows 10 1903 yesterday. When disconnecting an RDP session (no logout, just disconnect), the dwm.exe of the RDP host surges cpu usage until the RDP session gets connected again. Upgrading Graphics drivers (Intel HD Graphics P630) didn't help.
Same issue here on my NUCi5BEH and the Group Policy fix worked for me as well.

For me the issues started after KB4505903 was installed.

Thanks for the Group Policy tweak!

Wow, thanks for finding a quick fix to this problem. I have several older machines that I recently updated to windows 10 using build 1903 and every single one is experiencing high CPU usage after closing down an RDP session. Resource monitor after disabling the WDDM graphics display drive for RDP in the policy editor the cpu is running quiet at 2%. In the graphic I have logged back in to RDP session for illustration to show the CPU is now quiet and the fan noise from the laptops are now quiet after the RDP session. RDP does not run as smooth compared to when WDDM is enabled. Would be great if MS could fix this WDDM RDP bug.


The machines effected have older intel graphic processors including HD3000 and HD4000.

Jeff



here's the registry key for this

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Group Policy Objects\{91E7BA0E-CB36-4950-8236-D5E89A2E9D39}Machine\Software\Policies\Microsoft\Windows NT\Terminal Services]
"fEnableWddmDriver"=dword:00000000

Thanks for supplying the registry entry.  Microsoft had some RDP wormhole updates this week but did not fix the WDDM RDP bug.

just glad i noticed this bug tbh

I have an old laptop with an I7 2820QM with Intel HD3000

i have noticed the last few times after i have remoted into it

i come back to the lockscreen the cpu fan is going nuts

At first i presumed it was microsoft upto no good during idle times

e.g. virus scans or something even though its disabled via GPE

1903 has so many bugs

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.