Dual monitor Windows 10 not working properly after sleep mode

I have a new HP Windows 10 computer and and ACER G276HL monitor.

The monitor is set to be the primary screen and works well.

The issue I have is every time after the computer goes to sleep mode, all screens are moved onto the monitor, including the ones which were on the PC display when the computer went into sleep mode.  

Additionally, some screens (Excel seems to be the worst) open up wider than the monitor and I have to double click on the header to get it onto one screen, then I can maximize before using.

I have updated the monitor drivers - it uses the "Generic PNP Monitor" and ACER does not provide a Windows 10 driver for this monitor.

Any ideas?

Thanks.

 

Question Info


Last updated December 14, 2019 Views 16,560 Applies to:

Hi Brent,

Thank you for posting your query on Microsoft Community.

We regret the inconvenience caused to you. Let me assist you.

This is an issue caused when the graphics driver does not properly support sleep mode and therefore disabling the ability to detect a connected display when the computer goes to sleep. I suggest you to download the latest graphics drivers from the manufacturer’s website.

If the drivers for Windows are unavailable or the issue still persists, try installing the latest drivers in compatibility mode.

Follow the steps below on how to install driver in compatibility mode:
1. Download the driver from the manufacturer’s website and save it on your local disk.
2. Right click on the setup file of the driver and select “Properties”.
3. Select “Compatibility” Tab.
4. Place a check mark next to “Run this program in Compatibility mode” and select operating system from the drop down list.
5. Let the driver install and then check the functionality.

Also, install all pending updates on the computer. Updates are additions to software that can help prevent or fix problems, improve how your computer works, or enhance your computing experience.

 

Hope this information is helpful. Please do let us know if you need further assistance, we’ll be glad to assist you.

 

 

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Acer has a Windows 7 driver.

When I download it and right-click on the Setup File, then select Properties, there is no Compatibility tab.

I do see Compatibility Mode for Application Files, but not Setup Information files (.inf)

Am I missing something?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I am having the same issue, always have since I upgraded to Windows 10. Everytime my computer comes out of sleep it doesn't detect my second monitor so I have to manually go into Display Settings and hit Detect and then it works fine. I have a GTX 970 for my graphics card with latest Nvidia Driver 361.43. My two monitors are connected with HDMI on 1 and DVI on the other. The DVI monitor is the one that does not connect after my computer going to sleep. Any ideas? I have all latest Windows 10 drivers installed also.
Thank You
Liqueseous

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

After checking obvious (cables, Sleep setting) - Also check to see if "Allow this device to wake the computer" for the Mice, Keyboard

In Device Manager/ (right click) Mouse, Keyboard/ Power Management. 

What finally did it was the Network Adapter and Unchecking "Allow this computer to turn off this device to save power."

8 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.