Displayport no signal after Win 10 june update

i installed the new windows update (2004) yesterday (03/06). since then none of my displayports are working on my gfx card (rtx 2060). the cable is almost brand new. i have the latest geforce driver installed. the monitor works fine with hdmi and dvi. halp pls, its really frustrating. never ever had any problems with win updates before this. 
Sir, there is no Windows 10 June update, do you mean the May Update? So ok lets begin, Try removing the GPU and The cable and reset them again. This mostly happened with alot of users updating their win10.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Hello and thank you for contacting us. My name is Angelo and I am an Independent Adviser on here.

Try uninstalling all the Nvidia software and drivers

Restart the computer

Download and reinstall the drivers from here

https://www.nvidia.com/en-gb/geforce/drivers/

Regards

Angelo

________________________________________________________
Standard Disclaimer: There are links to non-Microsoft websites. The pages appear to be providing accurate, safe information. Watch out for ads on the sites that may advertise products frequently classified as a PUP (Potentially Unwanted Products). Thoroughly research any product advertised on the sites before you decide to download and install it.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

i tried all 3 displayport slots of my gpu, nothing changed. removing the gpu from the mobo and putting it back wud do nothing tbh. 

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

i did just that, i even reverted back to windows 1909 and still does not make it work. i had no issues until i updated yesterday. 

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

i found a solution. i had to turn off, then plug out from the power outlet both my pc and my monitor, then wait for a few minutes. thats it. its pretty blunt, but it solved the problem. 

1 person found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated April 27, 2021 Views 1,447 Applies to: