Disable Windows 10 automatic restart after updates

Is there any REAL way to disable this cancer feature?

This is not the first time i have lost unsaved work due to this annoying function, that almost every Windows user hates.

I'm trying to behave, but it is really hard to keep calm after loosing unsaved work multiple times.

Why is it that Windows cannot just wait until the user decides to restart at a convenient time? It's not like the end of the world that users doesn't restart at a specific time.

In a time where Apple's Mac is already "stealing" a lot of Windows customers, it is a very risky (and dumb) feature to add to Windows.

This alone is very difficult to argue against in a Mac vs. Windows discussion.

Luckily (for Microsoft) Microsoft have secured themselves from a law suit in their policy.

MS knows that all Windows users hates this feature, and yet they still have it. WHY?

So back to the question. Is there any official/unofficial way (FOR GOOD)  that allows me to disable this annoying feature?

I tried following some tutorials on YouTube, but little did it help obviously, as i just came home and found my computer restarted, and my work deleted.

 

Question Info


Last updated November 12, 2019 Views 7,230 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Is there any REAL way to disable this cancer feature?

Yes, of course. Setup active hours.

Start menu -- Settings app -- Update and Security -- Windows Update -- Change active hours

---------------------------------------------------------------------------
Not affiliated in any way with Directly or their Independent Advisors.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hello my name is Bradford and I'm an Independent Advisor for the Microsoft Community and I will try to resolve your problem.

1. Click on the “Start” button and type
gpedit.msc
press Enter.
2. In the Local Group Policy Editor, go to
Computer Configuration ->
->Administrative Templates->
-> Windows Components->
-> Windows Update
3. Double-click on “No auto-restart with automatic installations of scheduled updates”.
4. Select "Enabled", and then click "OK".
5. Close the local group policy editor.

If the above steps don't have the effect you desired please let me know!

24 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Is there any REAL way to disable this cancer feature?

Yes, of course. Setup active hours.

Start menu -- Settings app -- Update and Security -- Windows Update -- Change active hours

Thanks for your answer - but it's not useful. 

I asked if there is a way to REALLY disable automatic restart, and you answer me on how to change active hours.

2 very different things.

5 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hello my name is Bradford and I'm an Independent Advisor for the Microsoft Community and I will try to resolve your problem.

1. Click on the “Start” button and type
gpedit.msc
press Enter.
2. In the Local Group Policy Editor, go to
Computer Configuration ->
->Administrative Templates->
-> Windows Components->
-> Windows Update
3. Double-click on “No auto-restart with automatic installations of scheduled updates”.
4. Select "Enabled", and then click "OK".
5. Close the local group policy editor.

If the above steps don't have the effect you desired please let me know!

Thanks.

When i double click the "No auto-restart with automatic installations of scheduled updates" i get a popup in where i can enable the policy.

Though after enabling it, i get asked to set active hours.. All my hours are active. I don't want any restarts in active or inactive hours.

I just want Windows to stop restarting automatically no matter what time it is. I will restart myself when i need it.

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I asked if there is a way to REALLY disable automatic restart, and you answer me on how to change active hours. 

It's not possible to disable the restart, because the changes made by a feature update can only be processed while the computer is not being used. Most software operates this way.

---------------------------------------------------------------------------
Not affiliated in any way with Directly or their Independent Advisors.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hello,
Try the process below:
1. Press Windows key + R keyboard shortcut to open the Run command.
2. Type the following path and click "OK":
%windir%\System32\Tasks\Microsoft\Windows\UpdateOrchestrator
3. Select the
Reboot ) (it does not have an extension)
file right-click it and select "Rename".
4. Rename the Reboot file to "Reboot.old".
5. Right-click inside the folder, select "New," and click on "Folder".
6. Name the New Folder "Reboot".
7. Now restart your computer.

This will disable Window's ability to restart automatically.

If this solution has the desired effect let me know.

14 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

This is what I've had to do (the UpdateOrchestrator option posted by Omoikane1122).

To the other answers:
Active Hours are not a valid solution.  I leave my computer with long running processes over night, and I come back in the morning and discover my system rebooted.  This has cost me a lot of time and money.

S_and_S:
Yes, we can acknowledge that updates require restarts.  Nag me about doing them, that's fine, but DO NOT do it without my permission.  This is MY machine and the tasks I left running on it are MY livelihood.

28 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have the same issue. I am running computer simulations on my machine which take hours to days. You come back to your machine and it has rebooted, hussah! This is my machine and if I want to use it to make a living I don't want to lose work just because you morons think that an automatic reboot is a funny idea!

I don't want to change active hours. I tried the UpdateOrchestrator option but it already says "Disabled" for reboot, so that obviously doesn't work. And I don't have Windows 10 Pro so I can't use the gpedit option.

GET RID OF THIS F.....G BEHAVIOUR!

8 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

1: Only some hate this feature and I am not one of them. So happy!

2. What update is it? Only updates like the cumulative ones and cumulative.net... requires a restart. Plus, it will only ask for a restart after the update (cumulative) is done downloading and finished installing. Actually, after restarting, then it will counts as a successful install. Normally, Windows will not ask for a restart, or automatically restart, never heard off automatically restart unless it pertains to that update. I never have that issue before.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

1: Only some hate this feature and I am not one of them. So happy!

2. What update is it? Only updates like the cumulative ones and cumulative.net... requires a restart. Plus, it will only ask for a restart after the update (cumulative) is done downloading and finished installing. Actually, after restarting, then it will counts as a successful install. Normally, Windows will not ask for a restart, or automatically restart, never heard off automatically restart unless it pertains to that update. I never have that issue before.

Well, count me as another who hates it.  Giving me no option after downloading and installing an update (which does not warn the user of this ahead of time) other than to have my computer restart without my consent once my active hours (which can only be set to a maximum of 18 hours) are over.... that's simply not acceptable.  There is no valid reason to prevent users from postponing the restart for as long as we wish, and doing it at a time of our choosing.  Anything else leaves me inclined to disable updates altogether.  These are *our* computers, not Microsoft's.  If they can't understand that, they'll be left in Linux's dust.

For those that consider Linux too small a contender for that last sentence to be anything but a joke:  consider that Android is just a modified Linux OS, and currently holds the largest market share among all internet-connected devices, having overtaken Windows by 2017.  Not long after Windows 10 was released, come to think...

And if you search on Microsoft's own bing.com for <disable windows 10 update automatic restart>, you get over 28 million results.  That's more than if you search "Avengers Endgame", for an indication of how popular the idea of disabling this "feature" is.  When a customer asks for something, a smart business doesn't respond by trying to tell the customer why they shouldn't want that instead of actually giving it to them.  And no, I'm not going to pay for a more expensive version of Windows so that I can use gpedit to disable this stupidity that never should have existed in the first place.  Trying to frustrate me into paying more isn't a great business plan, either.

11 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.