Disable Ctrl + Mouse Wheel Scrolling Zoom in Windows 10

When you press the control key and scroll the mouse wheel, whatever window you are hovering the mouse over will zoom in or out, and this is extremely annoying if you are switching between typing/copying/pasting and scrolling though a file. Not only that, but you may have inertial scrolling and start to scroll and then afterwards press control and suddenly things will start zooming.

There are several complaints about this "feature" in Windows 10 in the Microsoft Community. I searched for answers for a while and ended up finding it on a Stack Overflow thread which was discussing this occurring in Chrome. However, this feature applies to pretty much every application. 

The solution requires the program AutoHotKey. (There is no native windows solution using the regedit or control panel).

- Download Autohotkey:  https://www.autohotkey.com/

- Create a text file with the extension ".ahk", (for example we can call it "disableMousewheelZoom.ahk" in  the StartupPrograms folder (i put it in "C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Startup")

- in that file, put the lines: 

^WheelDown::return

^WheelUp::return

- save the file. right click on the file and select "Properties". In the section "Opens with" select the Autohotkey.exe file you just downloaded.

- Right click on the AutoHotkey.exe file. Click the "Advanced" button. Check the "Run as Administrator" checkbox.

(Alternatively, you can put the script in your user-specific startup programs folder and not have to do the last step) 

|

Was this discussion helpful?

Yes
No

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this discussion?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this discussion?

Thanks for your feedback.

 

Discussion Info


Last updated September 16, 2021 Views 4,652 Applies to: