Desktop icons move to secondary monitor rather than staying on primary monitor after bootup

Greetings!

I am using Windows 10 64bit.

I used to have only 1 monitor(24"), I recently added a second monitor(20"), and I run into an interesting issue.

I already set the big 24" monitor as primary monitor, but somehow, every time I boot up, all desktop icons go to the secondary monitor(small, 20")

Although I can manually select, click and drag all icons back to primary monitor, it is annoying and time consuming.

Anyone here with brilliant idea that can help me to make sure all desktop icon to stay on primary monitor after boot up?

Thanks in advanced.

 

Question Info


Last updated February 20, 2020 Views 5,433 Applies to:
Hey there Sos, wouid you mind trying this out for me?

Right-click on an empty space on the Desktop, click on View.
Uncheck the option Auto Arrange Icons.
Check the option for Align the icons to grid.

Please keep me updated.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hey there Sos, wouid you mind trying this out for me?

Right-click on an empty space on the Desktop, click on View.
Uncheck the option Auto Arrange Icons.
Check the option for Align the icons to grid.

Please keep me updated.

Hi,

Thanks for the prompt reply.

I tried already, no luck.

I also tried other solutions from other posts, including

1.  running SFC
2. deleting IconCache.db
3. deleting desktop.ini

4. unplugging and re-plugging the hdmi cable
5. updating display card driver
6. resetting the main display option in display settings

any other ideas?

Thanks.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Go to Taskbar settings (right click on Taskbar) and scroll down to Multiple displays, apparently you can possible make the desktop icons switch from monitor to monitor by changing "Show taskbar on all displays".

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Go to Taskbar settings (right click on Taskbar) and scroll down to Multiple displays, apparently you can possible make the desktop icons switch from monitor to monitor by changing "Show taskbar on all displays".

Again

Already
no luck

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

And you already set your left monitor as the primary display? I didn't have this issue with my two monitor setup, but my single monitor is actually experiencing this after an unexpected shutdown.

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.