Default Printer keeps changing in Windows 10

We have two usb printers connected
DTC1250E and DCP 132W 

As long as they are connected in that  order . Then we can set the DCP132W to the default printer and the muster report runs to it . ie right click on a note pad file and it prints to the DC)132W

We can log off and log on as different users and all stay correct. If the computer reboots and checks the printers to see which is the default . The tick is on the DCP132W but right-clicking on a note pad file is sent to the DTC1250E 

Orginal title : USB Printer

|
Answer
Answer

Hi John,

Thank you for writing to Microsoft Community Forums.

I understand that the default Printer keeps changing after you restart the computer.

  1. Did this issue started recently? If yes, then what are the recent changes that you have made to the computer prior to this issue?

Method 1:

I suggest you to try turning off “let Windows manage your default printer” and check if you are still facing the issue.  To do so follow the steps below:

Open Start and select Settings > Devices > Printers & scanners. Turn off Let Windows manage my default printer.

If you still have issues, please follow the suggestion in method 2.

Method 2:

Registry disclaimer: Important this section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs.

Please take a backup of the registry. Follow the steps given in the link below:

How to back up and restore the registry in Windows

  • Open the Run dialog box by pressing the Windows key and the R key together.

  • Type Regedit and hit the Enter key.

  • When the Registry Editor opens, navigate to the following location:

            HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Windows

  • In the right pane, right click on “LegacyDefaultPrinterMode” and click modify to change the value of LegacyDefaultPrinterMode from the default 0 to 1.

  • Restart your computer.

  • Try setting you default printer again. 

Hope it helps.

Regards,

Zaki

1 person found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated October 7, 2021 Views 5,256 Applies to: