Connection fail issue unable to determine fix, and 90 minutes on hold with wave was too much

Unable to send or receive messages for the Wavecable (malem2us) account. The connection to the server has failed.

Server: 'mail.wavecable.com'
Windows Live Mail Error ID: 0x800CCC0E
Protocol: POP3
Port: 110
Secure(SSL): No
Socket Error: 10060

Above is my email error,  windows 7 home professional, all updates active, running windows live mail, all POP info is good, my web browser will simply not connect to the mail server, but my phone will.   below is what my browser tells me when I try to access http://webmail.wavecable.com.....

This site can’t be reached

webmail.wavecable.com took too long to respond.

ERR_CONNECTION_TIMED_OUT

|

I'm still in the dark, but I heard a rumor that Wave Broadband was transitioning their e-mail to a new server or something, but I cannot reach it through my browser or my windows live mail program.

I CAN however reach it through my cell phone a galaxy S7....

I am losing money and falling behind in bills due to not being able to send out an invoice and this is killing me.  Wave still refuse to answer their phones on the Tech support lines.

Anyone have a clue how to remedy this?

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated August 14, 2020 Views 47 Applies to: