Can't set Chrome as default browser in Windows 10

Original title: Chrome in Windows 10

I have uninstalled and reinstalled Chrome several times. Windows 10 used to let me use Chrome as default browser but now I cannot select anything for default. The icon keeps degrading which is when I uninstall and reinstall. 

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi,

 

Thank you for posting your query in Microsoft Community.

 

Please share a few details to narrow down the issue:

  • Are you facing this issue only with Chrome or other browsers also?

  • How are you trying to set it as default?

  • What exactly happens when you try to set it as default?

 

Feel free to get back to us with the required information to assist you further. We will be happy to help.

 

Regards,

Jenith

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

start chrome

chrome reports it is not the default browser, "click here to make default"

click button, windows settings form (from control panel) opens

browser default is EMPTY

click + and choose chrome (or firefox, same behavior)

close settings form

Actual:

NO CHANGE IN DEFAULT BROWSER.

Expected:

CHROME BECOMES DEFAULT BROWSER

am administrator, even tried running chrome as admin, no change.

PLEASE FIX THIS BUG.

14 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,

Thanks for the response and update.

I suggest you to uninstall the browser completely and then install the browser and follow the below steps.

1.  Type Default Programs in the Search Bar and then Enter.

2. Click on Set your default programs.

3. Select the particular program which you want to make as a default and then click on Set this program as Default.

THIRD PARTY LINK DISCLAIMER

Disclaimer: Using Third Party Software, including hardware drivers can cause serious problems that may prevent your computer from booting properly. Microsoft cannot guarantee that any problems resulting from the use of Third Party Software can be solved. Using Third Party Software is at your own risk.

Reply us if you need any further assistance on Windows 10 we will be glad to assist you.

 

14 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

There's a reason why no one else has responded to your answer Anup.  The steps you mention are exactly what the original poster said.  Uninstalled the app several times, tried setting something other than Edge as the default but without success.

I have the same issue also.  I have done all the same that anyone with even the slightest knowledge of windows would have done.  Still the same result. 

Is there a bug?  If not, what are the steps other than the obvious ones mentioned needed to resolve this?

29 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Craig,

As a workaround, use the classic Default Programs UI for setting the default browser. In the Default apps window, click Set defaults by app. This opens the Default Programs Control Panel (Classic user interface, which still works great) where you can choose your defaults.

See also: [Fix] Unable to Set Default File Association Using Default Apps in Windows 10

ex-MVP (2003-2012) (Windows Client)

120 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Ramesh

Thank you very much.  I went with the deleting the account option and it worked.  You're exactly right in that I recently moved from using a MS account to a local one.

Thanks again for your help.


6 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Craig,

Excellent. Thanks for letting us know which one worked.

ex-MVP (2003-2012) (Windows Client)

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I also have this problem with the browsers Mozilla, Opera and chrome
Ramon Marquez - http://www.windtux.com

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thanks

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,

The following worked just fine.  I would suggest a popup in the Setting / Default Apps where you can't change them from there even though there is a listing and implied way to change them.

As a note, I have shutdown as many things as I can from a privacy perspective.  I found the default Win10 setup appalling relative to privacy. I would never join Facebook, for instance.

1.  Type Default Programs in the Search Bar and then Enter.

2. Click on Set your default programs.

3. Select the particular program which you want to make as a default and then click on Set this program as Default.

5 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

 
 

Question Info


Last updated August 13, 2020 Views 34,652 Applies to: