Cannot change file type associations in Windows 10

Last week (09/29/2018) I was screwing around trying to fix a driver issue I was having on my Windows 7 install, long story short I screwed something up and could no longer get the OS to load. So I figured hey if I have to reinstall Windows might as well install 10. So I wiped out the by drivers partitions and started to do a completely fresh install of Windows 10. Fast forward to today(10/03/2018) and I have figured out fixes for most of my major annoyances with Windows 10 but one. I CANNOT change file type associations using ANY method built into the operating system.

System Info:

Windows 10 Pro x64 Build1803

Local account only

How I have tried to set the application to be used...

1) "Right Click" on file > Open With... > Choose Another App > Find and select app and check "Always use this app" > Ok

2) "Right Click" on file > Properties > Change... > Find and select app > Ok > Apply

3) Settings (Windows Key + i) > apps > default apps > Choose default apps by file type > Find file type > Pick app from list

4) Settings (Windows Key + i) > apps > default apps > Set defaults by app > Find app and click manage > No actual option to add the file type

What I have tried to fix the problem...

1) Deployment Image Servicing and Management

2) System File Checker

3) Control Panel Classic (Well couldn't actually try it as MS has removed those pages)

4) Deleting any MS Account info stored on the computer (Account used to sign into the MS app store)

As a temp workaround I have found some 3rd party applications that can do what Windows seemingly cannot do so its not all doom and gloom, but it is rather depressing that this is an issue to begin with.

So, Any thoughts on how to go about fixing this?

Cheers,

Rogue

UPDATE1: I noticed in task manager that after every attempt to set an application to use, a new instance of "OpenWith.exe" starts up and persists until I terminate the process or logout/restart/shutdown.

UPDATE2: For those that find this and are at least looking for temporary workarounds...

1) FileTypesMan

2) Default Programs Editior

3) https://superuser.com/questions/841497/windows-open-with-application-not-appearing-as-an-option/1020255

UPDATE3: Another application workaround
Total Commander - an alternative to File Explorer

UPDATE4: For my use cases this issue has been resolved after installing the following update

November 27, 2018—KB4467682 (OS Build 17134.441)

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

This seems to be an issue related to local user profile. To test this hypothesis, can you try to do same with a Microsoft account and see whether these association stick.
Best regards
Vijay Verma

Timezone: UTC+05:30, PST+12:30
Availability Hours (UTC) : 05:00 AM - 05:00 PM

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

This seems to be an issue related to local user profile. To test this hypothesis, can you try to do same with a Microsoft account and see whether these association stick.

Just for clarification are you asking for me to...

1) Convert my local account to a Microsoft linked account

or

2) Create a new user as a Microsoft linked account

Thanks,

Rogue

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

No need to do any conversion. Ideally, there must already be a Microsoft account on your computer. If not, create one.
Best regards
Vijay Verma

Timezone: UTC+05:30, PST+12:30
Availability Hours (UTC) : 05:00 AM - 05:00 PM

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

No need to do any conversion. Ideally, there must already be a Microsoft account on your computer. If not, create one.

So I went with option 1 and converted my account to a Microsoft linked account because as I said previously my account was a local account only.

These are the steps I followed...

Settings (Windows key + i) > Accounts > Your info > Sign in with a Microsoft account instead > Followed Prompts

After that was completed I attempted to set a default application for a file type using these methods...

+ "Right Click" on file > Open With... > Choose Another App > Find and select app and check "Always use this app" > Ok

+ Settings (Windows Key + i) > apps > default apps > Choose default apps by file type > Find file type > Pick app from list

Neither method worked

Cheers,

Rogue

UPDATE: Tried several combinations of linking and unlinking my account and rebooting the system without any luck either. At this rate I am considering going back to Windows 7 because Windows 10, even from a fresh clean install, seems to still be a dumpster fire.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Oct. 8, 2018 - Same problem here. I just bought a new PC and I cannot change a file extension. If I have Junk.docx and rename it to Junk.zip, it remains a .docx. 1st time I have ever experienced this.

Windows 10-64 bit

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Oct. 8, 2018 - Same problem here. I just bought a new PC and I cannot change a file extension. If I have Junk.docx and rename it to Junk.zip, it remains a .docx. 1st time I have ever experienced this.

Windows 10-64 bit

That seems to be a different problem than what I am having. For example, I have a text file that by default uses Notepad to open, but I want to use Notepad++ for text files instead. I do not have the ability using the traditional user options to change which application opens a text file.

For your problem it sounds like the file extension is not actually being changed and so you are ending up with a file that is actually named "Junk.zip.docx", but I could be wrong as I don't have enough details.

A quick check could be done by enabling "File name extensions" under the view panel on a file explorer window.

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Judging by how things went silent I am assuming there is no actual fix for this issue that I am having other than reinstall and hope it doesn't happen again.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Try one more thing. 

Go to File Explorer and click on VIEW. On the right there is a tab that says Filename Extensions. Click on it. This may save you a lot of trouble.

6 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I've got exactly the same issues and have tried the same things pretty much. I only have a domain account on my computer but tried it on a fresh install with a local account as well and got the same issue.

The only thing that I've seen that makes it work a little bit is to get an application to try and set it itself with the old API that worked on previous Windows versions. Then you'll get a error notification that says that an application tried to set it. After you've done that for an extension it seems you can actually change it for that file extension correctly. All others still fail though.

Someone needs to take a good look at this and solve it ASAP because this is a dealbreaker. I've lost hours of my time trying to fix this and loose more by the day since files won't open properly...

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Actually, my current college prof. gave me the solution. Please see my previous posts for it. 

Bob

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

 
 

Question Info


Last updated September 6, 2020 Views 7,779 Applies to: