Audio driver issue after windows update 1909

Hi.

I have updated my windows with the new feature update, and suddenly my speaker audio quality dropped (it sounds like a phone speaker now)

So here is my setup: 

MSI b350 gaming pro carbon motherboard

AMD ryzen 2700x

32GB Corsair Vengeance pro ram

Nvidia GeForce GTX 1070ti

I use a headset in the aux port and a Samsung N400 Soundbar in the optical audio output.  (Realtek Digital output)

I figured from the start that this probably is a driver issue so I immediately went to device manager to update audio drivers. However, the driver for my soundbar is "Audio Endpoint" from Microsoft, and it should be a Realtek high definition audio driver (v 6.0.8746.1). This driver is installed on my computer, but it is shown as not compatible with my hardware. This worked before, so I uninstalled the windows update but still not working.  

I have tried googling for help but I have not found anything that works. Any idea how can I fix my audio?

EDIT: I have narrowed it down to the fact that the device was not migrated successfully after the update. Device SWD\MMDEVAPI\{0.0.0.00000000}.{94ec45f3-b3a8-43d3-be66-27c5c24bd403} was not migrated due to partial or ambiguous match.

Hi and thanks for reaching out. My name is Anthony.
I'm Independent Advisor and I'm happy to assist you.

I understand how difficult it is, when the device or app won't work in the way it should.

Please check the different solutions indicated in the link below that can address this certain issue.

https://support.microsoft.com/en-ph/help/452028...

Hope it will help.
Please let me know if you need any further assistance.

Thank you and Keep Safe.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi. Thanks for the reply. 

Unfortunately, I went through all of these steps but they did not fix anything. 

The audio device was not migrated according to device manager and I think that is the problem, however I have no idea how to fix this.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Good day!!!

Please refer on the link below that might help resolved this issue.

https://answers.microsoft.com/en-us/windows/for...

Hope it will help.
Please let me know if you need any further assistance.

Thank you and Keep Safe.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

 
 

Question Info


Last updated July 4, 2020 Views 24 Applies to: