April 2018 update broke Chrome browser (Cryptographic Services bug)

I updated to the April 2018 version of Win10 a couple months ago. It caused several issues and broke my Chrome browser completely, so I reverted back to the old version. But Microsoft forced another update on me, so I need this issue fixed somehow.

All the googling I've done says Microsoft has "fixed" this issue with the April update breaking Chrome, but I've installed all patches and they clearly haven't, not in my case. Pages simply refuse to load and time out.

I've narrowed the issue down to the "Cryptographic Services" service. If I stop the service, all of the Chrome pages instantly load and I have no issues for about an hour. It seems to be some sort of issue with certificates/SSL.

The problem is the service keeps restarting itself. I've tried setting it to "disabled," tried unchecking the service in System Configuration, nothing works. It always comes back and Chrome breaks. I'm sure there's good reason to keep it running but I'm not going to let Microsoft force me out of my favorite browser/bookmarks/extensions/etc. like this, and I can't keep stopping a service every hour just to browse the web.

So I need a solution please. And something specifically related to fixing the issue with Cryptographic Services preventing SSL on Chrome. I've done all the basic stuff like reinstalling Chrome, checking firewall settings, etc..

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi Bob,

For us to sort out this problem with Chrome, please perform the following steps:

  1. Launch Chrome and kindly open an Incognito window.
  2. Try opening or accessing any websites.
  3. If the websites open, then clear its cache and cookies.

You may also remove unnecessary extensions from your browser to free some space. Here's how:

  1. Launch Chrome.
  2. At the top-right corner, click More .
  3. Select More tools, then Extensions.
  4. Identify the extensions that you don't use, then click Remove.

If the above steps won't work, then please start your PC in safe mode and perform the following:

  • Stop and restart the Cryptographic Service.
  1. Right-click the Windows key and select Command Prompt (Admin).
  2. At the command prompt, type in net stop cryptsvc, then press Enter.
  3. Type in net start cryptsvc, then press Enter.

  • Run the System File Checker tool.
  1. In the search box on the taskbar, enter Command Prompt.
  2. Press and hold (or right-click) Command Prompt (Desktop app) from the search results and select Run as administrator.
  3. Enter DISM.exe /Online /Cleanup-image /Restorehealth (note the space before each "/"). (Note: This step may take a few minutes to start and up to 30 minutes to run and complete.)
  4. Enter sfc /scannow (note the space between "sfc" and "/"). 

Please update this thread with the results so we can further check on the issue should it persist.

Regards.



4 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I am having the same issue and none of the above solutions worked. I have to stop crypto services every time I want to use Chrome.

4 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I'm having this same problem, seems to becoming a wide-spread issue.

Did a full, clean install to Windows 10 Pro, and after it installed the feature update 1803, all my apps are now broken

- Chrome

- Vivaldi

- Microsoft Store

- Edge

- iTunes

I have to stop cryptographic services for these services to work, and opening various apps seems to start crypto services which then makes it incredibly annoying.

MS need get a patch for this and fix it.

MS technician - do a google search for "windows 10 cryptographic services chrome" for the past month and you'll see this is a thing, not just a one-off.

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Some How-To Geek information on Chrome crashes ---

https://www.howtogeek.com/363826/why-is-chrome-telling-me-to-update-or-remove-incompatible-applications/

I don't know if this will help you or not.

It's still worth reading.🙂

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Yea that doesn't help.

One thing I'm pointing out is that this is not limited to chrome, it seems that other apps that need to make HTTPS requests also are experiencing this.

I was trying to use the Microsoft Store app to install iTunes, and I had to kill crypto services so that it would load the app page in the store. Once I installed iTunes and tried to sign in, I had to kill crypto services again for itunes to work.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I am having the same issue.

That's my way i fixed:

1. Open Run and type in regedit

2. Go here: HKEY_CURRENT_USER\Software\Microsoft\SystemCertificates\Root\

3. Right-click ProtectedRoots > Permissions and pick your account .

    Tick Allow Full Control

4. Right-click Root and Export 

5. Open Task Manager > stop Cryptographic Service and Delete Root(HKEY_CURRENT_USER\Software\Microsoft\SystemCertificates\) key in Regedit.

6. Restart your Windows.

Enjoy.

81 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Seems like a valid fix, but do you know what this actually does? for example, I have a program that will only run with Cryptographic services running. will I be able to use it or will your suggestion prevent me from using it? 

Thanks.

3 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I am having the same issue.

That's my way i fixed:

1. Open Run and type in regedit

2. Go here: HKEY_CURRENT_USER\Software\Microsoft\SystemCertificates\Root\

3. Right-click ProtectedRoots > Permissions and pick your account .

    Tick Allow Full Control

4. Right-click Root and Export 

5. Open Task Manager > stop Cryptographic Service and Delete Root(HKEY_CURRENT_USER\Software\Microsoft\SystemCertificates\) key in Regedit.

6. Restart your Windows.

Enjoy.

This actually worked!   Thank You!!

14 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

None of these suggestions worked, I have tried them all. I need a real fix. Come on Microsoft, a quick google search shows many people with the same issue. When are you going to fix this?

4 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

There are several local problems that can cause Chrome to block with ERR_TIMED_OUT during 'Establishing secure connection'. 

If stop/start CryptSvc or running IE/Edge before starting Chrome fixes Chrome, then the regedit delete ...Root fix will likely work.

There is a scripted registry repair here, but it requires an admin powershell and turning on execution policy, which is not much simpler than Nover's regedit instructions above.  It does have some additional checks and restores built in, so it's a little more robust, but does basically the same thing.  It's my script and will field questions posted there.  For more details see the Best Answer at the top of the thread or the Chrome bug CR838707.  

The essential part of the fix is deleting ProtectedRoots.  It will get rebuilt automatically.  Stopping CryptSvc is always temporary.  It gets restarted from many places.  When it restarts, ProtectedRoots gets rebuilt.  I'm not sure deleting Root is needed, but it gets rebuilt too, so deleting both is safe.

I'm not sure what the root cause is.  It seems like it's either the permissions or inheritance of the registry key.  Either way it's ok on rebuild.  The fix could also be a side effect of the rebuild.  The SystemCertificates/Root tree exists in several locations in the registry, some shadow or inherit from others, so tracking down the real root cause has been elusive.  The problem also impacts managed institutional environments and user profiles, in which case the per user fix above it not workable.

I'm not sure why the problem occurs.  It happens after a Windows (monthly) update or after a fresh install and update.  It only affects isolated users.  It's been around since April 2018 (aka 1803) and persists with the 2018 Fall feature update (1809)

This MS community thread is the closest I've come to finding a Microsoft mention of 'this' problem.  The Chrome team can't reproduce the problem, so it's not getting any official Google attention.

If you find others, let me know.  Maybe if we can get enough attention, we'll see a real fix.

If you have 'this' failure mode, the registry repair is the only fix.  

7 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

 
 

Question Info


Last updated October 13, 2020 Views 30,934 Applies to: