After new Windows update, Edge won't open to my chosen page...

Hello! Just installed the new May Windows update, and now when I open Edge, it only opens to the Microsoft page, not my chosen page. I have my chosen local news page set in Settings under "Settings: Appearance: Open to a specific page". It opened there before the update, now I can't get it back, even restarted, etc. What else do I need to do here? Thank you, Steve.

|
Hello Steven,

I'm John an Independent Advisor and a Windows user like you. I'll be happy to assist you today.

It seems the latest version of Microsoft Edge(91.0.864.37) had a bug and some community members also faced the same problem. I recommend reporting the issue through the Edge Feedback Alt+Shift+I to notify the Edge Team. They're now investigating the issue and hopefully release a fix soon.

Please try the temporary solution below until Microsoft resolves it.

Open Edge then paste this to the address bar

edge://settings/search

Press Enter
Search engine used in the address bar = select Bing(Recommended)
Please check if the issue still persists.

Kindly let me know if this helps or if you have any further concerns.


Kind regards,

John DeV
Independent Advisor

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

John: that "fix" did work for now, and I did report it to Edge Feedback. I'm glad I wasn't the only one this happened to! Thanks for your help, Steve.

Steve

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Hello Steven,

You're welcome. I'm happy to help.

Stay safe and have a great weekend!


Kind regards,

John DeV
Independent Advisor

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Steven,

I see if "Show feature recommendations" flag is disabled, the startup page works correctly.

Paste this in the address bar:

edge://flags/#edge-show-feature-recommendations

Disable the flag and restart your browser.


Sumit

Volunteer Moderator- Microsoft Community
I do not work for Microsoft

Mark the reply as helpful or answered to help others if your query is resolved

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Thank you Sumit; John DeV has provided a fix which is working. I will keep your suggestion on hand.

Steve

Steve

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated June 1, 2021 Views 43 Applies to: