Black screen after first boot of updating a Surface RT device.

Hi, 

I recently trying to update my Surface device. After the reboot, my device display the Surface logo then when into a black screen, and only the mouse is appearing on the screen and the screen stay in black for a long time, without any response. I try to reboot the device. But this problem persist. May you help me out? Also I tried hold power and volume bottom. It does not since to work.

Thanks.

Answer
Answer

Dear all,

I have finally solved the problem. There are two ways of solving it. I will explain both of them carefully.

PROBLEM: After the update of the system, the screen is black, only the cursor can be seen, and also the wifi icon on the left part of the screen, appearing and disappearing.

SOLUTION 1:

This solution works, I have tried it.

You have to start the system from the scratch and install all of the updates proposed but one: KB3033055. But pay attention: this update is proposed two different times:

The first one, as a part of a very loooong list of updates; in this moment, it has to be accepted and installed, and no problem will happen.

Later, this update will be proposed in a short list of six optional updates. At this moment, you have to accept all the rest of the KBs, but not KB3033005. Since it is an option, you can simply skip it but not selecting it.

After installing all the updates but KB3033055, you have to restart the system and try to find more updates, which can be installed with no risk. I’m writing this comments on February 27th, and every update prior to today is OK but KB3033055.

Now my system is ready, steady, smooth and functioning. Everything runs perfectly.

After updating everything but KB3033055, the system has 42 GB free (my table is a Surface RT 64 GB). Probably there will be more or less 15GB in Surfaces RT 32 GB.

Even though somebody stated that the February update solves the compatibility problem with KB3033055, I have tried to install KB3033055 AFTER February update and the black screen comes back again. Since I don’t need it, I won’t try it (maybe later, or in another life…!!).

SOLUTION 2:

Maybe you don’t want to start the system from the scratch. Or maybe you did it and later, without paying attention, you did install KB3033055 and the black screen problem reappears.

This solution is inspired by the solution proposed by the user called timpeq in this thread: https://answers.microsoft.com/en-us/surface/forum/surfwinrt-surfupdate/surface-rt64-update-kb3033055/6f38b3b1-82ff-4ef0-bcfa-4416c8ccf79f

(Timpeq replied on February 13, 2018. I have not been able to follow his instructions (maybe you will), but some of them have been useful.)

You have to follow these steps:

  1. Turn off the Surface by pressing the on/off button for some fifteen or twenty seconds.

  2. Once you are sure that the Surface is off, press the side button (reduce volumen), and, without releasing it, press the on/off button for one or two seconds. When the Surface logo appears, you have to release the volume button immediately.

  3. The Surface will start in a safe mode, and the “Wait” message can be read after the Surface logo. If not, turn it off and start again the process.

  4. Then, you have to go to the Command Promt (by this way: Troubleshoot, then Advanced, then Command Promt).

  5. The system will ask for the Bit Locker code. That code is a long code (8 numbers of 6 positions each, separated by “-“. Like xxxxxx-xxxxxx-xxxxxx-xxxxxx-xxxxxx-xxxxxx-xxxxxx-xxxxxx, obviously each x is a number. If you don’t have the code, you can get it in this url:

    https://microsoft.com/recoverykey

    Please, note that you have to login with your Microsoft ID and password to get your Bit Locker code.

  6. Once you enter the Bit Locker code, you have to select your user (it will appear in your screen), and use your password.

  7. The Command Prompt will appear (you know, the classic black window with the prompt letter, which in my Surface is: X:\>

  8. You have to write this command. Do it VERY CAREFULLY, taking into account that even blanks are important. Even though you see it here in two lines, everything must be written in only one line, without any space between "remove-" and "package": ".../remove-package /packagename...":

    X:\>dism /image:c:\ /remove-package /packagename:Package_for_KB3033055~31bf3856ad364e35~arm~~6.3.1.19

    I don’t know if this command Works for all kind of Surfaces RT, but it is valid for Surface RT 64 GB.

    Important: For typing ~ , you have to press AltGr + 4, and then spacebar.

    Important: There is a blank space (spacebar) among \ and / in: “image:c:\ /remove-package”.

  9. The Surface will uninstall KB3033055. Wait until the percentage of uninstalling is 100%. It will take some minutes. Be patient, it looks like nothing is happening when it arrives to 99,5%, but you have to wait. Don’t touch anything and don’t restart.

  10. After the uninstallation (when the porcentage gets to 100%), write “exit” and press enter:

    X:\>exit                        [and press enter]

  11. After that, you can continue with the start process. Your Surface will come back to life again. Like magic!!

I have tried both solutions on my SURFACE RT, and both of them work.

Good luck.

Álex Cerrollo

73 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

 
 

Question Info


Last updated July 19, 2020 Views 15,112 Applies to: