Microsoft Surface Pro (2017) BSOD PDC_WATCHDOG_TIMEOUT pdc.sys with Trend Micro Anti Virus

Hi,

I've been getting bluescreens for a few days now after a while of doing nothing.

The tablet is currently unused next to me but is on and the display is off, eventually comes just the said BSOD and the part restarts.

Have current Surace Pack on Win10 and current updates.

What could be the PDC_WATCHDOG_TIMEOUT?

The triggering file is pdc.sys.

 

Question Info


Last updated September 18, 2018 Views 23,640 Applies to:
Answer

My Company is experiencing the exact same issue with our Surface Pro Fleet of Devices (1796 & 1807); Trend has been fairly helpful but still yet to confirm a proper fix & it's currently not on the Developers Radar for future fixes.. The "workarounds" suggested & that I've deployed to a few Surfaces are proving successful. 

Trend Micro's Response: 
As per checking deeper on the DMP files that was collected, as per our Developers; the issue is because Behaviour Monitoring is unable to handle events from sleep mode. So indirectly, it leads to PDC.sys, or DAM.sys to BSOD.

--CUT--

PROCESS ffffbe830f8e8640
SessionId: 0 Cid: 196c Peb: d48258b000 ParentCid: 0368
DeepFreeze
DirBase: 126388000 ObjectTable: ffffce8bc4bc6480 HandleCount: 2212.
Image: TMBMSRV.exe

--CUT--

 

Suggested Action Plan to apply for testing, provided by Trend Micro: 

1. Rename AEGIS drivers and create a folder with same name

c:\windows\system32\drivers\tmcomm.sys
c:\windows\system32\drivers\tmactmon.sys
c:\windows\system32\drivers\tmevtmgr.sys

(ps: Take tmcomm.sys for example, rename it as tmcomm.sys.bak, then create a folder named tmcomm.sys)

2. Create the following registry key entry: 

[HKEY_LOCAL_MACHINE\SOFTWARE\TrendMicro\aegis]
PowerMonitorTime=dword:0x10


Still awaiting for further development & feedback from Trend but have yet to experience a BSOD with the above mentioned Action steps followed.

Note our case is still opened with Trend Micro, I'll post updates as they occur. 

| Windows Systems Administrator | Technologist | Freelance Motorsport Photographer | Gamer/Streamer |

30 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Answer
I uninstalled Trend Micro Anti Virus and the problem went away.  We are now using Symantec Antivirus.

7 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.