Surface Pro 4 type cover suddenly not working.

I don't know what happened. I turned my Surface Pro 4 on the other day and the type cover is dead. No lights. No response. No indication that it's working at all.  I rarely take my surface anywhere. 

This started on July 9th 2018. My system information is below. I've gone through all of the steps in the "Troubleshoot your Surface Type Cover or keyboard" page. I've tried to manually download and install the latest firmware and drivers from the "Download firmware and drivers for surface" page. I picked SurfacePro4_Win10_16299_1801701_1.msi. My device manager does not show the "Surface Touch Cover Filter Device" under keyboards or anywhere. It only shows the HID keyboard and cannot detect my type cover. The type cover is completely unresponsive. Also, my windows updates are completely up to date. I've provided the links to the troubleshooting pages I used below.

AGAIN, WTH

Troubleshoot your Surface Type Cover or keyboard

Download drivers and firmware for Surface 

Edition
Windows 10 Professional
Version
1803
OS Build
10.0.17134.165
Serial #
035060755053
Processor
Intel(R) Core(TM) i5-6300U CPU @ 2.40GHz
Graphics card
Intel(R) HD Graphics 520
System
OSType64BitX64
RAM
8 GB

 

Question Info


Last updated July 16, 2019 Views 20,905 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

I'm in. link:

https://m.facebook.com/groups/493808644458973

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I solved the problem with my surface pro 4.

1) I disconnected the cover type from the surface .

2) I disconnected the surface itself from electricty ( charger) .

3) left the hall unit disconnected like that, overnight.

4) in the morning I connected the keyboard ( cover type ) to the surface and the surface to electricity, and cover type worked as usual.

Seperating the parts as I described worked like hard reset.

It works (temporary) as you described until next reboot with connected power or full battery. So it looks like it has something to do with power management of our surface.

I spend around 2500€ for a premium device: first I had to replace it because of flickering screen, then my surface pen stopped to work, and now the type cover is dead. grrrrrrrr Microsoft what is going on?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thanks! count me in

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

https://www.facebook.com/groups/493808644458973/ 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

https://www.facebook.com/groups/493808644458973/

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

It seems as windows update 1803 caused the problem with the type cover. Temporaily solution is by draining the battery (disconnect the ac) and disconnecting the type driver from the SP4 . it works for several days till the type cover stopped working again and I ha d to repeat the formula again.

However MSF has to solve this problem which looks more and more as software problem caused by their update 1803.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thanks guys - at least you seem to have honed down on the issue:

so its something to do with the power handling software in the Surface: 

My wife's surface pro 4 type cover just stopped working a few days ago and I went through the usual route:

cleaned the contacts

removed the driver

reset the machine to a point in October

checked the driver had been re installed

etc etc

ZILCH

i then spent a half hour cleaning the contacts multiple times with alcohol/qtips till everything was shiny bright ( with the power off of course ).  re-attached the cover and bingo it worked or so I thought.  worked for a day then died again

in desperation we got another type cover to try - no dice.

then i read all your posts - pulled the power cable off and it works fine.  Reattach it and it works till the batt charges up fullly then it dies again.

tried this several times now - very repeatable.

COME ON MICROSOFT:  THIS IS YOUR HARDWARE AND SOFTWARE AUTO UPDATED BY YOU  - FIX THIS ISSUE !!!!!

PS

I quite like the Surface ( when it works - and my wife likes it a lot ).  For myself I use win 7 for engineerging work with legacy software and I have moved to the dark side for everything else - it does my head these days in trying to fix win10 problems.

Great forum btw

Richard in the UK

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Did I say reproducible/repeatable? - what a laugh

Just went down again on reboot with about 65% charge only

BTW the unit is at win 1803 not 1809 which hasn't reached this installation yet.

Just got a bluetooth keyboard to use the thing. 

Disgraceful!!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Same thing happened to my Surface Pro 4. Right around Veterans Day weekend, I had some updates that needed to be installed. Saved my work and allowed the updates to install. Went to bed and the next morning my type cover would not work. Spent two days on the phone with Microsoft premier support and they offered to ship me a replacement surface pro for $450 since it is out of the 1 year warranty. Yeah...not happening since I’ve only had it for a year and i did nothing to the surface except install the updates.

The closest MS store is 3 hours away so i drove there on Sunday to have their engineers look at it. They tried everything i tried and verified my type cover works, just not on my surface. They tried reimaginf it and that didnt work either. The manager told me my options were to pay $450 for a new surface pro 4 or pay $799 for the new surface pro 6. I argued and said i shouldnt have to pay for something they broke. They told me they were WELL AWARE OF THE ISSUE but would not offer any solution.

I wish MS would treat this like the red ring of death on the Xbox 360. Offer to extend our warranty for another year (for like $100) and ship our surface to MS to have them fixed. If it cant be fixed, then MS will ship a refurbished unit. Why cant they do this?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I am one of the many who know this is not a hardware problem. My issue, like so many others, occurred immediately after an update. The Surface had not been moved. It was fine, the update occurred, and then it stopped working.

There appears to be two things happening

1. It appears to be a new firmware being installed incorrectly. The firmware itself doesn't appear to be faulty, but something happens when it is being installed.

2. Microsoft washing their hands of what is a widespread problem, just claiming that all of these people somehow damaged their hardware and the very moment an update is installed. Similar issues existed with the Surface 3 last year, and similarly Microsoft just claimed that all these users all became suddenly clumsy just for the very moment the update was installed.

While I can't help those in the USA, I will be raising complaints in NZ with everyone I can.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.