WiFi/Networking issue when connected to docking station

Hi,

I recently bought the new Surface Pro 4 (i7, 512 GB SSD) along with the new docking station. I've experienced some of the general issues that various other people have mentioned (such as the power management/sleep issue) but I'm also seeing an issue that does not yet seem reported.

When I have the new docking station connected, if it's connected to a monitor, the network connectivity sometimes drops. I have been using it without any issues for about 2 weeks, but today I had a lot of trouble connecting to the office WiFi network. The network itself was definitely working properly as it was quick and reliable for several other users, including my own phone. Nonetheless, I rebooted the router to make sure.

Windows simply would not connect to the WiFi network (even though it has always been a saved connection). Trying to connect caused it to sometimes fail and sometimes ask for the network password (and entering it correctly would still fail - but that's another long-standing Windows bug!). Connecting to alternative networks did exactly the same; it would attempt to connect to my phone's portable hotspot, connect and disconnect in a few seconds, retry, and then stop (in a disconnected state). Intermittently it would connect to the network, but sometimes with 'No Internet' and clearly lots of DNS issues in trying to resolve google.com. It sometimes took 30-60 seconds to load google.com.

Troubleshooting steps

  • Tried disabling and re-enabling the WiFi adapter
  • Tried restarting Windows 10
  • Tried disabling all other network adapters (the Ethernet port from the dock and two created by VirtualBox)
  • Tried removing dock connection
    • This is the first time the connection issues were resolved and google.com was loaded (and could be reloaded) within milliseconds
  • Re-attached dock and tried removing Logitech unifying receiver (the only USB device plugged in)
  • Tried removing monitor
    • Everything back to normal, was able to browse very quickly again
  • Tried re-attaching monitor
    • Network issues again where loading google.com would take around 20 seconds and refreshing the page would also take several seconds

Clearly there is an issue with the external display. The display is a 1080p monitor which is connected via a HDMI cable and a Mini DisplayPort to HDMI adapter. The strange part is that this problem has never come up before, though in hindsight I would say that browsing at the office has been generally a little bit slower than at home.

Has anyone else experienced this issue? I might try to get an older pre-1.4 spec HDMI cable to see if this has an effect.

 

Discussion Info


Last updated November 19, 2019 Views 26,437 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

I can get my LAN working through the Docking station, but when I unplug, the wifi doesn't work.... seems to be specific to Surface 4 (i7, 500GB SSD, 16 GB). My Surface Pro 1 is fine and so is my 2008 MacBook.

This is the latest in what has turned out to be the worst computer purchasing experience I've ever had. 30 hours of trouble shooting.

I have the dock connected via display port adapter to hdmi port on an Acer 27" touch monitor. I have EXACTLY the same symptoms and issues as above. In the beginning it was more temporary issues, but now it is so bad I cannot use the network when using the dock at all.

I also have numerous other surface pro 4 issues, like pen sometimes not working, keyboard disconnect issues etc. I come from a Macbook, and am not sure if these issues are "normal" Windows issues, or specific to the surface pro.

As a note: To get the needed custom resolution for my 27" monitor, I had to manually install the Intel display drivers(!)

I use my Surface Pro 4's wifi with the Xfinity modem router combo.

When I connect the Surface Pro 4 to the Surface Dock, I cannot access the internet.

When I check the settings, the Surface Pro 4 shows that it is connected to the router, but will not transmit any data.

I have tried the usual steps of unplugging the modem and restarting the Surface Pro 4.

As soon as I unplug the Surface Dock, I can immediately access the internet.

I used the ookla speed test when connected disconnected from the Surface Dock and saw that my upload and download speeds were normal.

When plugged into the Surface Dock, my upload and download speeds were 0 and 0.

I would appreciate any help I can get.

Thanks,

-Jose

@Jose -

Welcome to the Surface Dock Ethernet port problems.  Sounds like you're experiencing identical Surface Dock Ethernet misbehavior as I did.  Performed similar steps to yours with my router, had similar findings.  See this thread:

http://answers.microsoft.com/en-us/surface/forum/surfacc-surfpower/surface-pro-4-dock-ethernet-connectivity-problems/cea55eb9-db31-464e-b737-1253fa7ff757

As best I can tell, your choices today are:

1.  Power-cycle the Surface Dock (unplug AC power and re-plug) every time you use it, or at least once daily.  This may help somewhat, although some Surface Dock lots will not even respond to this approach.

2.  Wait for Microsoft to acknowledge the problem and issue software and/or firmware updates that stabilize the behavior of the Ethernet on the Surface Dock when paired with SP4s.

3.  Vote with your feet and return your Surface Dock, get your money back.

Regrettably, after my 2nd Surface Dock with same problem over past 2 months and no acknowledgement or help from Microsoft, I finally was forced to opt for #3

Wow, I wish I had known that this was an issue before.  I'm not even using my ethernet cable, but wifi instead.  I don't really want to run a cable to where my desk is.  What is the point of the dock if it disables my internet?  I suppose I'll be contemplating returning it.  Sometimes I just need extra screen real estate space when I'm doing certain kinds of projects while being connected to my external hard drives and other devices.  It would be great to have a video on the big screen playing with One Note open on the Surface it self.  If I can't get internet, what's the point?  Maybe there is a third party product that can fill my needs.
I have a surface pro 4.  I purchased 2 docking stations, one for work and one for home.  At work the docking station is perfect and uses an Ethernet cable.  At home I only have WIFI, when I plug in the docking station the WIFI no longer works, it says it is (i.e. it is connected) but won't transmit data.  As soon as I unplug the docking station, wifi works perfectly again.  Some reason I think it is trying to use the Ethernet adapter on the docking station.  Any suggestions?  I like the docking station as I can power 2 monitors and plug in several USB devices.

I have similar Setup with Surface pro 4 and Surface dock,  

Same problem of no internet on WIFI connection.  

Every time I disconnect the docking station cable. I do get my internet back on wifi, i.e. wifi connection is established between surface and router and internet is fine. But when I reconnect the dock, the issue is back. 

I tired reporting it to Windows support guys on chat, they asked me to contact Surface support.

Link below

https://www.microsoft.com/surface/en-us/support/contact-us

I will trying reaching them next week. will keep you guys posted.

Anybody tried reaching surface support on this issue?

In case any case, we all should report the issue to surface support.


Hi all

I had the same problem and found the SOLUTION.

When I plug in the Surface Dock I need to plug it in so that the wire is hanging on top (so plug the cable with the head of the cable facing down). This way the Wi-Fi works when connected to the new surface dock. If plugged differently it does not work.

This solution works for me - please try and see if it solves the problem.

Bersant

I tried this, does not help. Only thing that works is to unplug the mini displayport cable. Microsoft sent me another dock, same issue. So maybe the SP4 has a defect? Maybe driver? Frustrating that Microsoft cannot fix this.

A tech from Microsoft has requested me for a troubleshooting session, with remote access. However I will need to take a day off from work to do this.

After some Struggle contacted Microsoft support.

Some solution proposed are.

1> Windows Update for All device.

Go to settings-->Update and security-->Windowsupdate-->Advance options--> select the check box "Give me updates for other Microsoft product when i update"

2> Update WIFI driver

Do to device manage --> Network adapter--> right click "Marvell AVASTAR wireless-AC Network Controller" to Uninstall.

*Do not tick the option "delete the driver software for this device "

click OK and restart the device.

after doing above two options. it seems to work for me. but I am not 100% sure. I will test it for a week and let you know the problem is solved.

3> Last option was enable Recovery in windows and reinstall windows. 
(this i have not tried)

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.