Disk usage at 95-100%

For some reason, my disk usage spikes up to 95-100%, which causes my fan to turn on. I am not doing anything particularly demanding (e.g., web browsing, One note, Office, etc.), which makes me wonder why this is happening. 

Looking in the task manager, the offending processes are:

Service host local system
Outlook communications
Unistack service group

They will all take turns spiking up to 2-3 Mb/s. It will go like this for 20-30 minutes and die down for a while, only to spike up again later. I'm not sure what it is exactly what it is I'm doing to make this happen.

I've looked online and it seems like many are having this problem, but no solution has been found.

I'm using a brand new (less than a week old) Surface pro 4, and this is already the 3rd issue I've had with it (high CPU, missing notifications, now this). This is getting really annoying...Does anyone have a solution?


 

Question Info


Last updated March 28, 2019 Views 1,262 Applies to:

Hi mayxx248_,

Thank you for sharing your experience here. Please make sure your date&time are correct and manually check&install updates. See steps below. You can also see our latest update information for Pro 4 here

Kind regards,

Clare

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I already had the updates installed. That wasn't the issue.

Actually, I found that uninstalling the Microsoft mail and calendar apps did the trick. Not seeing disk spikes anymore.

4 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

How did you uninstall said apps? I had a  similar issue and finally had to do a system reset (not fun) and the problem has ceased so far.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Here is how you uninstall things like Mail and Calendar:

http://www.howtogeek.com/224798/how-to-uninstall-windows-10s-built-in-apps-and-how-to-reinstall-them/

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

thanks, great information!

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

my computer is completely up to date and it has this problem where it will run like 95% to 100% of battery with its fan.  I am also having massive battery issues from normal usagae.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.