No wireless device after upgrading Surface Pro 3 to Windows 10

Hi all,

This morning I got the prompt to upgrade my SP3 to Windows 10, and the upgrade process was very very smooth (good job MS).

However... once it was done, I get no wifi networks at all - in fact, it's almost like I don't have a wifi card, which obviously is impossible :)

I have tried pretty much all the suggestions available here (https://www.microsoft.com/surface/en-us/support/networking-and-connectivity/install-wireless-drivers?os=windows-8.1-update-1) and none worked. I downloaded the SurfacePro3_150623.zip file, went to Drivers\Network\WiFi and installed mrvlpcie8897.inf but no luck.

Device Manager reports my wifi adapter as a Marvell AVASTAR Wireless-AC Network Controller (which seems about right to me) but I still get nothing...

Help?

Answer
Answer

I solved my problem. After rolling back to Windows 8.1 I uninstalled and deleted all Cisco VPN and Cisco AnyConnect software form my Surface Pro 3. Also deleted the Cisco adapter in device manager.

Downloaded the Windows 10 upgrade again and after installation everything works fine. Wireless and also Bluetooth.

Tip form Cisco: You will want to make sure you are using v4.1MR4 or 3.1MR10, these are the supported versions for W10. http://ow.ly/QeyHk  

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Answer
Answer
Did all of you guys have Cisco (or other) VPN software installed before the upgrade?  If so remove it.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated May 1, 2020 Views 20,653 Applies to: