Surface Pro 3 High CPU load when idle, high system cpu load

Has anyone else noticed that coming out of sleep or herniate results in unwarranted high cpu load from system interrupts? 

I have all the latest firmware and updates loaded. But using sleep even sometimes a cold boot I get this issue.

How can I fix this please. Its killing my battery life.

 

Question Info


Last updated August 5, 2019 Views 18,473 Applies to:
Answer
Answer

Dear Clare,

No, this is not what I was asking. Please refer to the original question.

Perhaps you may have something running in the background.

Frank J Garcia (ctitanic)
Surface MVP
http://www.ultramobilepc-tips.com

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Answer
Answer

Oh!! I just checked it again as I wanted to make a screenshot and now it's working! I don't know what changed. The only thing I did was that I originally enabled Hyper-V but when it started interfering with my WiFi connectivity I disabled it again, so maybe that's what was necessary.. I used to have constant high "System Interrupts" process running, but disabling one by one I found out that an Adobe startup process was causing it, so I disabled it and it seems to have fixed the issue. Either way, thanks for your responses!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.