Surface Pro 3 Slow WiFi - 72Mbps Max (driver)

I have an Apple Airport Extreme 802.11ac wireless router at home and am only connecting at a max of speed of 72Mbps (usually closer to 11Mbps if I'm more than 20 feet away from the WAP). I have two other 802.11ac laptops at home (Samsung AB9+ and rMBP) and my two other computers are connecting up at 800Mbps+ and pulling down the same on Internet speed tests; yes, I have real GigE connectivity. Is anyone else having these problems?

 

Question Info


Last updated October 12, 2019 Views 33,276 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

I have an Apple Airport Extreme 802.11ac wireless router at home and am only connecting at a max of speed of 72Mbps (usually closer to 11Mbps if I'm more than 20 feet away from the WAP). I have two other 802.11ac laptops at home (Samsung AB9+ and rMBP) and my two other computers are connecting up at 800Mbps+ and pulling down the same on Internet speed tests; yes, I have real GigE connectivity. Is anyone else having these problems?

I have read at least one more user reporting the same issue with the AC connection and it seems that everything started after the  firmware update.

Frank J Garcia (ctitanic)
Surface MVP
http://www.ultramobilepc-tips.com

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

So I got my sp3 yesterday and it was blazing fast on wifi. I did all the new updates and after doing so every web page was loading slow or timing out.

I did some searching and there a bunch of people with the exact same problem "Other forum"

I cant use my 5ghz network which is my wireless ac. I have a netgear nighthawk and the only way i can use this sp3 is by using the 2.6ghz now.

Please fix this. I'm shaking my head that first update screwed something up.... i already went through nightmares with my sp2 so this isnt a good start :( 

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

The last firmware update may be the cause of that.  Pro 3 models received a firmware update that slowed down WiFi and you may be able to perform a REFRESH and reinstall you updates - but - this time, if you see a firmware update, click on the list link just below it in the Windows Update panel and it will display all updates pertaining to it.  The one listed as FIRMWARE, right-click on it and tell it to 'hide' the update.  Then, go ahead and install the others.

Eventually, that firmware update will sneak back into the updates automatically but maybe, then, it will be fixed with a patch.

I don't have a Pro 3 myself "yet" but everybody who has RT and Pro models in the past that had troublesome firmware updates had to do that for function.

Give it a shot, you don't lose your files in a REFRESH.

James R. Vinyard

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I've been speaking with a number of other friends/family/colleagues that also picked up Surface P3s on Day 1 and they seem to be having the same issues. 802.11ac compatibility seems to be the worst, but even 802.11n speeds seem to be worse than other stable devices.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I've been speaking with a number of other friends/family/colleagues that also picked up Surface P3s on Day 1 and they seem to be having the same issues. 802.11ac compatibility seems to be the worst, but even 802.11n speeds seem to be worse than other stable devices.

Agree. I'm using 802.11n at 2.4 GHz. At 5 is not stable enough.

Frank J Garcia (ctitanic)
Surface MVP
http://www.ultramobilepc-tips.com

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

So I got my sp3 yesterday and it was blazing fast on wifi. I did all the new updates and after doing so every web page was loading slow or timing out.

I did some searching and there a bunch of people with the exact same problem "Other forum"

I cant use my 5ghz network which is my wireless ac. I have a netgear nighthawk and the only way i can use this sp3 is by using the 2.6ghz now.

Please fix this. I'm shaking my head that first update screwed something up.... i already went through nightmares with my sp2 so this isnt a good start :( 

We have other people reporting the same issue here too.  It's hard to release a device using a new technology and make it compatible with all the other devices in the market using that technology. Eventually MS will fix this issues but it will take some time.

Frank J Garcia (ctitanic)
Surface MVP
http://www.ultramobilepc-tips.com

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

So I got my sp3 yesterday and it was blazing fast on wifi. I did all the new updates and after doing so every web page was loading slow or timing out.

I did some searching and there a bunch of people with the exact same problem "Other forum"

I cant use my 5ghz network which is my wireless ac. I have a netgear nighthawk and the only way i can use this sp3 is by using the 2.6ghz now.

Please fix this. I'm shaking my head that first update screwed something up.... i already went through nightmares with my sp2 so this isnt a good start :( 

One more idea. If it was working before the update you may still have the drivers old version in your SP3 so it may possible to downgrade it. just an idea.

Frank J Garcia (ctitanic)
Surface MVP
http://www.ultramobilepc-tips.com

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Yea, this is getting to look like a rerun.

The news got out earlier today and the i3 and i7 models will be available on 1 August.  The i3 model was the one I was wanting - I don't need super fast or a lot of storage to use one for testing purposes and do some minor document work.

Oh yes, Microsoft invented a pair of pants that recharges mobile devices in a pocket (cellular phones).  I can't wait to see somebody wearing those in a rain storm!

James R. Vinyard

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

So I got my sp3 yesterday and it was blazing fast on wifi. I did all the new updates and after doing so every web page was loading slow or timing out.

I did some searching and there a bunch of people with the exact same problem "Other forum"

I cant use my 5ghz network which is my wireless ac. I have a netgear nighthawk and the only way i can use this sp3 is by using the 2.6ghz now.

Please fix this. I'm shaking my head that first update screwed something up.... i already went through nightmares with my sp2 so this isnt a good start :( 

One more idea. If it was working before the update you may still have the drivers old version in your SP3 so it may possible to downgrade it. just an idea.

Exactly, your can go back to this one an see if that helps.

Frank J Garcia (ctitanic)
Surface MVP
http://www.ultramobilepc-tips.com

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I've been speaking with a number of other friends/family/colleagues that also picked up Surface P3s on Day 1 and they seem to be having the same issues. 802.11ac compatibility seems to be the worst, but even 802.11n speeds seem to be worse than other stable devices.

Try downgrading the driver.

of course, this is just a workaround.

Frank J Garcia (ctitanic)
Surface MVP
http://www.ultramobilepc-tips.com

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.