Has anyone successfully used Clonezilla in Surface Pro 3?

We have been using Clonezilla to capture and restore image to computers. Our company decided to make the switch from laptops to Surface tablets. We are still in the testing stage with Surface, but we can't seem to use Clonezilla to capture the image. I can boot from a usb with Clonezilla but when the window to choose the language comes up, Clonezilla freezes. Another issue we have been trying to figure out is when we do sysprep OOBE, the Surface crashes.

Anybody had any success with imaging Surface Pro 3?

Thanks!

Jonald

 

Discussion Info


Last updated May 7, 2020 Views 7,115 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

I'm actually in the process of doing that as I speak/type!

This guy posted the following...

http://community.spiceworks.com/how_to/89307-how-i-got-clonezilla-to-image-our-surface-pro-3s

However, I didn't do this (I read this after I had started).

Its a bit of a pain, mainly due to the single USB port but mitigated if you know the gotchas!

I decided that, due to the single USB 3 port, rather than use a flash drive, I'd use a USB HD instead so I could put both the clonezilla live image and the images on it.

I used: Tuxboot to ensure the HD was bootable with Clonezilla live.

http://clonezilla.org/liveusb.php

Gotcha 1).  Ensure you format the HD as Fat32 for booting Clonezilla (this requirement related to EUFI in the Surface Pro).   If you don't do this then your tablet will not boot from the USB and will just return you to Windows.  In my case I created two partitions, a very small Fat32 drive and the rest was an NTFS drive for my images.  I'm guessing you got all this based on your post above but this is for completeness for other interested readers.

Gotcha 2).  The surface pro has some kind of protection on it which inhibits what it classes as unsafe boots.  You need to disable this in the (minimal) BIOS.  To avoid repetition (and save me some typing), check out the top link from this post for info.  Additional to this I had to mess around with Bitlocker settings once I had disabled this secure boot thing.  Again, you must have solved this according to your post.

Gotcha 3).  After doing all this and booting from the USB drive (details in the other post on how to boot from USB for other readers), the Surface Pro keyboard stopped responding after the Linux boot.   I initially thought the thing had frozen but this was not the issue.  Maybe this was your problem too? It is at exactly the same point (language selection) where it *appeared* to have frozen.  I suspected some driver issue so then I experimented and got a USB HUB out, plugged in a wired keyboard and rebooted.

This time all was well.

Its literally just finished saving the image now.  Dare I attempt to restore from image to test it....

Yup.  I have the Windows rescue disk to hand, just in case.

If this turns out to be a problem then I'll update this post.

Regards,

Martyn

Damn it, I went to the bathroom and tripped over the USB cable while attempting to restore the image!

So I've started it again though it seemed to work so far.

I was thinking of a way of doing all this without a HUB (for better portability).  I guess it's possible to create a bootable microsd card and just use the single USB port on the Surface Pro for the wired keyboard.  That is assuming you have enough room left for the image(s).

For speed of restoration/saving images, I'm going to try partition the Surface Pro's main drive and use the second partition to store disk images.  That is if I can shrink the main disk.  SD's don't like to be defragged!

Booting clonezilla from microsd and using the surfaces pros own (partitioned) SSD to store the disk images worked a treat if anyone is interested (after a few teething problems).  It now restores in around 7 minutes and I just need a USB keyboard and the microsd (no hub or anything else).

Obviously you want to take a backup of your disk image elsewhere though.

Oh and, do yourself a favour and disable BitLocker in the control panel unless you really need the additional security.

Seems to have quite an impact on the SSDs performance.

Hello Martyn,

Can you outline please how you managed to successfully clone the Surface Pro 3's using Clonezilla, I'm in the process of trying to setup 40 units but I'm not having much luck!

I've been using Clonezilla for many years so I know the basics of it, but trying to run it on these machines I'm getting all kinds of errors.

I'd already come across the Spicework posting which I've followed.

What version of Clonezilla did you use?

To outline my setup I've got:-

64GB Surface Pro 3

I've setup Windows from a clean install from scratch - updated drivers / firmware etc

I have an External USB 3.0 driver, with 1 small Fat32 Partition which contains Clonezilla Live, and a 2nd NTFS partition which contains the images.

USB 3.0 Four Port Hub

USB Keyboard

On one occasion I managed to create an image file with no problem, but when I tried to restore it to another machine it just fails.

I've spend hours and hours trying to get this working, and it's starting to get me down now!!

Any help / advice / tips / gotchas that have not already been mentioned would be great as I've tried all my usual tips and tricks from doing this sort of thing for the last 10 years and this has really failed me :-(

I've also tried using FOG but can't get it to see the FOG boot menu from PXE boot (using the official Microsoft USB Adapter) and I've also tried getting my head around Windows WDS / Deployment Workbech - but this works in a totally different way to Clonezilla/Fog and I find create a custom image is sooooooo slow to try and restore!

I really hope somebody can post me an answer to what I might be doing wrong with these machines!!!

Thanks

Matt

 

Hi Matt,

Sorry to hear you are having difficulty.  I hope my reply does not come too late, I haven't checked this email address or this post for a while.

I used the latest version of CloneZilla and I used the latest version of TuxBoot to make the MicroSD bootable.

It sounds like you are doing all the right things, Fat32 for CloneZilla live, etc.

In what way does it just fail?  

Does it fail to *boot* after restore?  

Does it fail *during* restore? 

Does it give you some error code/description?

If it is failing during restore (and I'm totally guessing) I wonder if your hub is causing you problems while restoring from the Ext USB drive?  Does it work when using an internal partition or microSD card?

From the sounds of it, you are definitely getting to boot CloneZilla and select options.  I am using the basic/beginners option, not touching key map, etc and (after a few teething problems) its all working fine for me.

I did at first make a mistake in that I saved the *disk* rather than just the partition to image and I had problems when I attempted to restore that from the image.

So then (after I rebuilt my destroyed OS from Windows backup) I saved just the main partition to image.  I didn't touch any of those other partitions that Windows creates (two at the start I think) though I did eventually destroy the windows restore partition (at the end of the disk) to save space.

It all worked pretty smoothly for me after this, I made another partition image just this weekend.


I'm a programmer by trade so this is just a hobby for me and my preferred backup solution so I'm afraid so I can't comment on PXE.

Thank you for the reply! It wasn't too late... I'm still struggling to get it to work!

I totally flattened the Surface Pro 3 and reinstalled Windows from a fresh install onto a reference machine - I deleted the partitions and allowed Windows Setup to create these partitions. (I'm installing Win 8.1 Enterprise)

I have managed to create a successful image file of a Surface Pro 3 DISK but it fails on restore, using different versions of clonezilla I've had mixed results - one version (can't remember which at the top of my head) restored sda1 sda2 sda3 and failed whilst restoring sda4 which I believe Is the C Drive partition in my case.

The version I'm currently trying again creates the image fine but when I go to restore I get the message saying unable to find target partition sda1 and doesn't then attempt to restore.

i did try just doing an image of OS partition, but that failed too - I'll try doing another reference image tomorrow on a fresh machine and leave the other partitions in tack and try just taking a clone of the OS partition again and see if that works!

do you know what variation of the latest build you used? Did you use the Ubuntu based version or Debian - and was it the amd64 version or i686-pae ? I'm assuming you used the latest stable version or was it latest testing?

I've attached some of the screenshots I get when I try and restore.

Whilst ive been trying to get Clonezilla working in this scenario- I've also been trying to get it to work with MDT and custom image files but find that so sloooow compared to sector imaging like Fog/Clonezilla!

Thanks again,

Matt

Morning Matt,

Jeez - what a headache!  

As you are alluding to, this does definitely look like a software/version issue.  There's no other magic I've done to get this working above and beyond what you have already done and I strongly suspect you know a lot more than me in this field.  I guess I've just been lucky!

For me I used the latest stable release - "clonezilla-live-2.3.2-22-i686-pae.iso".

I just used the i686-pae drop down for file type ISO from this page...

http://clonezilla.org/downloads/download.php?branch=stable

I'm also just using the Windows 8.1 version that come installed on the Pro but I suspect the OS has nothing to do with this issue.

I read in other forums that people recommended using the uEFI secure boot version though I don't think the one I successfully used was this secure boot.

From the error messages in your screen shots, it looks like it is an issue with setting up the partition table for the new gpt format.  Ironically maybe the uEFI secure boot version is causing the issue?

Have you tried using the version listed above?  For both saving an image and restoring?

And it may be worth just trying the main partition initially, maybe even back to the same machine.  Just to test that this works, then build on from there if it does.

If you like (after work so it will be this evening), I can perform a backup and get my camera out so you can compare output?

Trying to think about this more logically, with regards to what worked and what didn't...

As I said, I didn't touch the first two partitions that Windows created before the main partition.  

I'm not sure why there are two but I guess *one* of these two must contain the boot loader and this must be in the GPT format for the EUFI bios to be able to see and boot from it.  Somewhere along the boot process this must pass execution control onto the main partition that has the Windows installation on it.

Now, given that all I saved/restored was the partition with Windows on it, then I guess its possible that CloneZilla in general has issues with setting up GPT formats and therefore this might explain why people suggest using this uEFI secure boot and why you are having limited success.

Your use case is different to mine as I am not needing to setup boot sectors and GPT disks.

I just checked in Disk Management.

I have the following (in order) on Disk 0...

1).  350MB Recovery Partition

2).  200 MB EFI System partition

3). 100 GB *NTFS* Partition - C:\ this is my Windows installation/partition.

4).  137.81 GB NTFS Partition - D:\ (a spare partition I setup so I could store disk images and other data on it).  Not relevant.

So, note that partition 2 is the EFI system partition - this must be the GPT formatted partition that the UEFI bios is using to boot from.  My Windows installation partition is just NTFS.

This givens me an even stronger suspicion that the issue is with CloneZilla not being fully compatible with the GPT format (or at least one must be very selective over picking the version to use).  It just happened to work for me because I only touched the NTFS partition.  It maybe there is a version that does work correctly with GPT (e.g uEFI secure boot) or maybe not.  This isn't a problem I've had to solve for my scenario.

What you could try first is just seeing if you can save/restore just your Windows Partition (as I suggested in the last post).  This might go along to confirm my suspicions.

Total guess work in general but, if that succeeds and you are lucky then it might be that the EFI system partitions created by the installation of windows DO NOT CHANGE between versions.  I.e.  Your enterprise Windows may have the exactly the same EIF system partition as the default one.  If that is the case then you will just be able to restore to the windows partition to clone your machines.  This should be easy enough to test.

Failing that, you are probably going to have to experiment to see if you can find a version that fully understands EFI.  This secure boot thing looks like the right way to go but I suspect you've already tried it.

Alternatively, used MDT or whatever else to restore just the EFI partition (this is only small so should not take long).  Then use CloneZilla just to restore the Windows partition as NTFS.

All of this assumes you want a version (of the EFI partition) created from a specific Windows version other than the stock installation.  If you are cloning/restoring just from stock EFI partition then I see no reason why just restoring a modified Windows partition alone (using the same version I did) should not work.  In short, don't touch the EFI partition with CloneZilla.

Let me know how you get on,  this could be a looong day!

Good luck!

Regards,

Martyn

Hi Martyn,

Thank you very much for your detailed responses - they're very much appreciated!! I've had a bit of a break thr today! I restored one of the Surfaces back to factory defaults using the USB key I created to make the Microsoft Recovery disk - this restored all the original partitions - I then then make a couple of changes on the desktop for testing and took an image of just that partition, the portion saved with no issues.

i then took a second Surface Pro 3 (with factory defaults in place) and restored the image to just the Windows partition and that worked!! So that was a success!

what I will try next is run the Windows setup and instead of deleting all the portions, I will leave them all as they are and just format the Windows partition to reinstall Win 8 Ent - then setup as I want and clone that partition do restore - I'm hoping (fingers crossed) that this will work!

I've posted on the Clonezilla forums to see if the developer has any idea why I'm not able to do a whole disk image to restore.

I'll update this topic with my findings when tested so others will know for future if they find themselves in the same position!

Many thanks once again!

Matt

Awesome, glad you got there in the end!

Again, this lack of being able to restore the entire disk probably relates to EFI and compatabilities with CloneZilla.  Hopefully the developer may be able to shed some light and suggest the right version for this problem!

Regards,

Martyn

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.