Surface Pro 2 - Surface cover telemetry driver / blank screen after putting tablet to sleep

Hi, 

I just picked up my Surface Pro 2 256GB today and it ran into problems right after applying the firmware update that seemed to have been released just today on Windows Update.  I confirmed this problem was caused by the firmware update because I restored the tablet and the wireless was working fine and I applied the firmware update and that broke the wireless.

After the update, the Marvell AVASTAR Wireless Composite Device stopped working...meaning, the tablet does not recognize the wireless card.  This is confirmed by going into the Device Manager and seeing 2 unknown devices (one of them was the wireless card, the other unrecognized device I will explain in the next paragraph) When I tried running the update driver function, it tried to reinstall the driver but returned the following error.

Windows encountered a problem installing the driver software for your device

Reinstall the drivers for this device (Code 18) 


I had to go the manual route and there were 2 Marvell drivers listed and one Microsoft driver listed for the Marvell card.  The 2 marvell drivers listed had exactly the same name.  However, only choosing and applying the second one worked.  So, the wireless was working again.

The other "unknown device" turned out to be something called "Surface Cover Telemetry".  However, trying the same troubleshooting process for the wireless card did not solve the problem and the devices still remains "unknown" in the device manager.  I just left it and carried on with installing my other software and apps as the tablet and the Type Cover 2 seemed to be functioning properly.

However, when I put the tablet to sleep by closing the Type Cover (while on battery power but charged up to 100%), the screen remained blank even though I opened up the cover again and tried to wake the tablet.  I knew that the tablet was still on but the screen remained blank even after I tried touching it, typing on the keyboard as well as briefly tapping the on/off button.  When I touch the Windows icon on the bottom frame of the tablet, I can feel a slight vibration and that told me that the tablet was on but the screen somehow is totally off.

I decided to do a soft reset of the tablet by holding on the on/off button for more then 10 seconds.  However, the screen only worked properly after many attempts.

My questions are, could it be that this "unknown device" that needs the "Surface Cover Telemetry" driver is causing this blank screen problem?  And if so, where can I download a driver that works?

Thanks.

 

Question Info


Last updated November 7, 2019 Views 29,447 Applies to:
Answer
Answer

Greetings all,

Please download and install the Surface Pro 2 System Firmware Update for March 11th. This is targeted towards the Telemetry Driver:

Thank you for posting,

Steven B

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.