How to connect my Surface Pro to a WPA2-Enterprise Network with PEAP authentication

Hello all,

 

I am trying to connect my Surface Pro to a WPA2-Enterprise Network with PEAP authentication at my work.  The company I work for has a separate wireless network for employees to connect personal devices to.

 

I am not a network admin, I have no access or knowledge of the how the wireless network is setup or the equipment/company that the network is setup on (i.e. I have seen Cisco listed in other posts as being problematic, I don't know if we use a Cisco network or not).  I haven't gotten our IT guys involved because it is clearly stated that our IT group doesn't fully support this network and we are on our own in getting assistance in connecting devices.

 

I don't believe there is any issue on the network side that would be causing me any problems as I have been able to connect an android smartphone (running ICS) without issue.  I don't know of anyone else having problems either, although I don't know of anyone else connecting with a Window 8 device, let alone a Surface.

 

I have tried the instructions on another post on this site (the instructions are quoted below) about manually configuring the network and that didn't work for me.  Changing the WPA2 Enterprise from AES to TKIP caused error message saying that my settings didn't match the network requirements. Using the AES option allowed me to hit "Connect" but it just sat there and eventually timed out before connecting.

 

I am not very knowledgeable about network connectivity or any of the settings/options, so specificity in the insturctions of any solution would be better.  Any help on this would be greatly appreciated. Thank you

 

 

 

"Answer

sfm5 replied on
Figured out a work-around.  It might be local to the wacky network configuration here, but might prove to be helpful for anyone else having the problem.  Here's how I fixed it:

1) Removed the <ssid> from my list of known networks
2) Went to the "Network and Sharing Center" in the Win 8 desktop
3) Manually configure a wireless network
4) Enter the <ssid> of the LEAP network 
5) Select WPA/WPA2 - Enterprise with TKIP 
6) Select PEAP as the Authenication Method
7)Goto Settings for the Authentication Method
a) Uncheck "Verify server's identity..."
b) Set Authentication Method to "Secured Password (EAP-MSCHAP v2)"
c) Click "OK"
7) Go to advanced settings
a) Specify Authentction mode = User Authentication
b) Set the user credentials (i.e., AD domain username/password)
8) Click "OK"
9) Connect to <ssid>"
Answer
Answer
Thank you. I could not connect and this has worked.

For anyone else having this problem I could not configure access manually because the network profile was configured on my RT although it was not displayed in the GUI.  I had to delete it and then configure manually using the above instructions.

To delete manually:
  1. Windows Key + X
  2. Open the command prompt (Admin)
  3. Type: netsh wlan delete profile name="ProfileName"
    (see http://windows.microsoft.com/en-us/windows-8/manage-wireless-network-profiles)
  4. Then follow the instructions above

HTH :)

Andrew

1 person found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Answer
Answer
If the IT guys at your workplace have set up this network with this level of authentication, then I cannot understand them not offering some level of support. The only thing I could say is that possibly they are using a different Authentication Method (Step 7b). You could try the other options to see if one of them sticks during the network setup wizard.

In my opinion, it would be best to involve the IT guys there as they will have the most knowledge of the network as well as view their logs to see where the authentication might be failing. If the Surface Pro is not joined to the domain and that is a requirement for connecting, that may be an issue too.

Best to speak to them if at all possible.

**Poster states that entering his credentials after the wizard when prompted by the network and using AES instead of TKIP worked for him**
I sometimes write about tech here:

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated December 21, 2020 Views 13,165 Applies to: