Why is my Surface Pro's screen turning off and locking after two minutes?

I cannot get my Surface Pro to just sit there with the screen on for more than 2 minutes. I have no idea why this is and is possibly the most frustrating thing in the world right now. I'm trying to monitor the progress on things while I work on my Desktop. I'm keeping the Surface Pro on my desktop as a visual aid and it keeps turning off.

I have gone into all of my power settings on the Desktop side of the operating system. I have set screen to dim and screen to turn off to NEVER on all 3 power plans for both plugged in and on battery. It STILL keeps turning off in exactly two minutes. Somebody please help.
 

Question Info


Last updated June 20, 2019 Views 22,741 Applies to:
Answer
Answer

As I mentioned above, I had already gone through all of the settings and nothing seemed to work. I finally unplugged my Surface and just let it sit there on battery and see what would happen. The screen didn't turn off. Apparently the changed settings didn't go into effect until I unplugged it. When I plugged it back in it seems that the new power settings were working. While I did seem to solve the problem, I think it's pretty ridiculous that the power settings don't take effect immediately.

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Answer
Answer

First make sure you don't have a screen saver set to activate.

If that doesn't help then:

Just to make sure:

 click on the power icon in desktop and choose more power options;

Click on change when the computer sleeps

Click on change advanced computer settings

Now expand the sleep options and make sure they are all off or set to more than two minutes (hybrid sleep and allow wake timers should be off)

Now go to power buttons and lids and make sure all options are set to sleep

Now go to display

  Make sure dim display after settings are set to a time you desire

  Same for turn off display after

 Turn off enable adaptive brightness for now (you can set it back on if you want once things are working)

Now go to multimedia settings and change when sharing media on battery to: prevent idling to sleep (you can change this back once things are working this is just to be sure you aren't having a problem with this setting)

Now click ok.

Does this fix the problem?

 

 

 

 

 

Please mark as answered or helped if it did, it can help with problems others may have.

8 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.