Micro SD card not recognised

Hi, I am using a 16GB Sandisk Ultra micro SDHC and another  64GB Sandisk Ultra micro SDXC in my Surface pro 128 that I have had for about a month;  I did have a 16GB card inserted for the first 2 weeks using as an additional drive then changed to the 64GB which I mounted as a folder/library.  It all worked fine until a few days ago, I turned the surface pro on and one of my icons on the desktop was a broken shortcut; when I went looking for the program it was not the be found (file location error).  I tried restarting, shutting it down, cold shutdown to the same effect.

When I eject the card, windows makes the familiar hardware removal sound, similarly it makes the sound effects when I insert a card but it does not appear anywhere (explorer, drive management etc...)

I though the 64GB card may be corrupted so tried the other 16GB card with exact same sound effects and lack of response/appearance.  I then tried the 8GB card out of my phone (which works in my phone), same story again.  Last card I tried was an old 512MB micro which did the same as all others.

I have a USB card reader that I inserted and every card mentioned (64, 16, 8, 0.5) showed up when plugged into the surface through the USB port so I do not believe any of the cards to be faulty.

The cards are definitely inserted correct facing and clicked in place properly; I noted that this problem had been listed by others.  I do not believe this to be the case as the hardware/reader was working fine.

I have tried searching for updated drivers though there appear to be no newer drivers for the card reader and as it is running the latest since new it has no rollback driver feature.  Tried disable and then enable device with no effect.

Last ditch effort, I ran a refresh of windows 8, inconvenient to say the least particularly as Office removed itself and my outlook cache is very large/slow to download once installed along with other work specific programs.

Problem still exists but appears to be different to those that other forum users have listed with their card reading problems.


Hi Hugo,


Excellent idea to check the disk manager.  The sd card was appearing (in all card cases) as an unallocated drive space.  This connects to mounting the card as a library/folder within the parent drive; which a number of users will be doing to use the micro sd slot as a hard drive extension.


I have now successfully remounted the drive/library to use again.  I am unsure of how this originated, likely that the card may have bumped out or encountered an error in recognition.


Now I wish I had done this prior to refresh (as I have to reinstall a number of programs).


Thanks Again, hope this thread helps others in future.

7 people found this reply helpful


Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.


Question Info

Last updated July 13, 2020 Views 13,022 Applies to: