Slow wifi after Instant On wake up

Hello,

I just acquired a Surface Laptop 3 13.5'' and I noticed that wifi becomes (way) slower after waking up from sleep mode. A speed test shows a decrease in the order of 90% (from 100 Mbps to 10 Mbps).

I am not alone (a couple of posts on reddit deal with this issue) and I think it affects all the new Surface devices with Intel Wifi 6. Is Microsoft aware of this issue? Because it makes Instant On feature completely useless if it costs 90% of wifi speed.

Note that I don't have issue with Ethernet.

Thanks.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hello,

I just acquired a Surface Laptop 3 13.5'' and I noticed that wifi becomes (way) slower after waking up from sleep mode. A speed test shows a decrease in the order of 90% (from 100 Mbps to 10 Mbps).

I am not alone (a couple of posts on reddit deal with this issue) and I think it affects all the new Surface devices with Intel Wifi 6. Is Microsoft aware of this issue? Because it makes Instant On feature completely useless if it costs 90% of wifi speed.

Note that I don't have issue with Ethernet.

Thanks.

Hi Kefeng(2) ,

Thank you for sharing your experience. You may consider running these troubleshooting steps to fix the issue.

Download and Run Surface Diagnostic Tool Kit

https://support.microsoft.com/en-us/help/4037239/surface-fix-common-surface-problems-using-surface-diagnostic-toolkit

Force Shutdown and Restart

Press and hold the power button for 20 seconds. This will clear the hardware's memory cache

Install latest updates

Go to Settings> Updates & Security> Windows update> Check for updates

Install drivers and firmware package

https://support.microsoft.com/help/4023482/surface-download-drivers-and-firmware-for-surface

For the 13.5" Laptop, choose the Surface Laptop with Intel Processor download.

Disable Background Apps
Settings> Privacy> Background Apps> Toggle off the apps that you don't want to run on background
 
Disable Pair to Pair Update
Settings> Updates & Security> Windows Update> Advance options> Delivery optimization> Toggle off "Allow downloads from other PCs"

Please let us know how the issue progresses.

Best regards,

GeraldAldrin_T

Microsoft Agent | Moderator

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hello,

try this Workaround:

1. Go to the hardware manager -> network adapter -> Intel AX201 -> Advanced -> MIMO power save mode -> Change "Auto SMPS" to "No SMPS". While this resulted in the bug occurring less frequently, only changing the setting to "Static SMPS" (-> disabling MIMO) eliminated the problem entirely for me.   

2. (Optional) Go to the Windows Settings App -> System -> Power & Sleep -> When my PC is asleep and on battery power, disconnect from network -> Change "Never" to "Always"


Explanation of the bug:  

The new Intel AX201 adapter has 2x2 MIMO, basically double the antennas for double the speed (if your router supports it). Now in standby Dynamic SMPS disables one antenna and the other antenna goes to a low power state. However the bug is that after waking up the device from standby, the second antenna is not activated and the other antenna remains in the low power state resulting in severely reduced speeds, higher latency, ...  

Since disabling SMPS leads to higher power consumption when in standby (both antennas remain active, possibly in a higher power state than necessary) I have included the second step where you can simply disable Wi-Fi while in standby. If you change the setting to "Static SMPS" this shouldn't be necessary, however you lose MIMO, ergo up to 50% slower speed.

Source:

PSA: Workaround for "Slow Wi-Fi after waking from sleep" problem (Intel AX201 adapter)
https://reddit.com/r/Surface/comments/dp96pb/psa_workaround_for_slow_wifi_after_waking_from/

The Workaround works on Surface Pro 7 also.

Best regards

3 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

>a couple of posts on reddit deal with this issue
>
 
link please?
 
I believe Microsoft is actually aware of this issue but they have not
acknowledged it here.
 
Barb
My Blog - http://digitalmediaphile.com/
MVP-Windows and Devices for IT
Windows Insider MVP

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

The Reddit thread I am aware of
- seems to state that the techs at the Microsoft Stores are aware of this. Is
there another thread on reddit stating Microsoft is aware of this issue?
 
Barb
My Blog - http://digitalmediaphile.com/
MVP-Windows and Devices for IT
Windows Insider MVP

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I'm trying to get someone from the Surface team to post here acknowledging the
issues.
 
Barb
My Blog - http://digitalmediaphile.com/
MVP-Windows and Devices for IT
Windows Insider MVP

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thanks for Assist and your Information. 

Best regards

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I'm trying to get someone from the Surface team to post here acknowledging the
issues.
 

Any update on this? It's been a few weeks now.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Not really, I've been told that "Wireless Roaming Aggressiveness configuration
settings are available in the Advanced menu of the driver and may improve
performance, although with some impact to battery life" and that they are
investigating.
 
Barb
My Blog - http://digitalmediaphile.com/
MVP-Windows and Devices for IT
Windows Insider MVP

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Based on this Reddit post - https://www.reddit.com/r/Surface/comments/dp96pb/psa_workaround_for_slow_wifi_after_waking_from/

You can change a MIMO setting in the driver settings as a workaround.

  1. Go to the hardware manager -> network adapter -> Intel AX201 -> Advanced -> MIMO power save mode -> Change "Auto SMPS" to "No SMPS". While this resulted in the bug occurring less frequently, only changing the setting to "Static SMPS" (-> disabling MIMO) eliminated the problem entirely for me.

  2. (Optional) Go to the Windows Settings App -> System -> Power & Sleep -> When my PC is asleep and on battery power, disconnect from network -> Change "Never" to "Always"

Obviously this still isn't a true fix and makes the hardware operate differently than expected.

Rob Russell
IT Pro, Microsoft Insider, Triathlete
My Blog - https://www.tecklyfe.com

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

 
 

Question Info


Last updated October 3, 2020 Views 3,873 Applies to: