How to disable Core Isolation on a Surface Book 3?

Good day everyone,

I' trying to run Nox Player ( on a new Surface Book 3, but Windows keep telling me it's not compatible. Following Nox's how-to guide, they say to disable Core Isolation, but according to Windows that setting is managed by the system administrator, when the Surface Book 3 is my own machine, with only one account on it, and of course with admin privileges.

I've tried a common gpedit.msc "trick" of changing a setting and then changing it back, but the Core Protection setting is always out of reach.

Are there special steps I need to take to disable Core Isolation on a Surface Book 3?

***Moved from: Windows 10 / Windows settings***


Hi, BriareosKerensky!



Thanks for reaching out to Microsoft Community and posting your inquiry.

To disable Core Protection, it is required to enable Intel VT-x. There's a thread that discusses how to do so and can be found at this page:

By design, this is turned off by default on your Surface Book 3 for the device's safety. Furthermore, Memory integrity is a feature of core isolation and it is important to have this enabled. Turning on Memory integrity setting helps prevent malicious code from accessing high-security processes in the event of an attack. 

Please check these links for further information:


If this answers your question, please let our Community know by marking this post as an answer. Otherwise, don't hesitate to respond to this thread if there’s anything else that needs to be addressed. 



Kind regards,


1 person found this reply helpful


Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.


Question Info

Last updated April 5, 2021 Views 481 Applies to: