Surface Book 2 Trackpad and Keyboard Lag

Hi. I have a brand new, i7 256 Surface Book 2 with an annoying problem. The trackpad and keyboard both exhibit huge lag when running on battery power, with anything less than "Better Performance". Even then, it's not perfect unless you go for the 'Best Performance' setting.

When running in battery mode, it's easy to appreciate that more people might be using the trackpad rather than a mouse (for portability) so why this won't function properly on the lower power saving modes, is confusing to say the least. One would expect the keyboard to work cum-what-may. 

I've never experienced this issue with my Surface Pros and feel rather disappointed given the cost or the Book 2.

Any fixes please, other than disabling the two-finger pinch to zoom function?

*** I no longer seem to be experiencing this issue ***

 

Question Info


Last updated August 22, 2019 Views 4,682 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

I have the same issue on my i7 512 Surface Book 2. The keyboard though works ok, at least I noticed no lag. The touchpad though lags a lot and it ruins the experience. In better performance mode everything works ok. I just hope that battery life is still good in this mode.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I've got the same problem and it's *really* *annoying*.  Additionally, once you put the Surface Book 2 in best performance mode, the fan starts running full-blast and battery life stinks.  Overall, I've found that battery life on the SB2 isn't particularly great.  

Any help from MSFT would be greatly appreciated.

-Ben

Benjamin Day - Microsoft MVP for Visual Studio ALM

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I'm having something similar, touchpad falls behind periodically with a sort of rubber-band effect, and then the keyboard lags just slightly -- enough to cause typos. I'm fairly certain, though, that this wasn't happening prior to a few days ago, and so it seems like in mine at least it's been caused by an update. I have a 15" 1TB.

I'm not seeing the same issue on another identical unit. I too would like Microsoft to respond to this issue.

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I'm experiencing the same issues (SB2 15" 512GB). I have found that putting the performance slider on battery to "Battery Saver" removes the keyboard lag and trackpad issues. This has to be some sort of power management issue or something, since I seem to have pretty poor battery life as well.  I'm testing battery saver now, and battery life already seems much better (25 minutes I'm still reading 100%, whereas I dropped 8% battery in 25 minutes earlier).

5 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I'm experiencing the same issues (SB2 15" 512GB). I have found that putting the performance slider on battery to "Battery Saver" removes the keyboard lag and trackpad issues. This has to be some sort of power management issue or something, since I seem to have pretty poor battery life as well.  I'm testing battery saver now, and battery life already seems much better (25 minutes I'm still reading 100%, whereas I dropped 8% battery in 25 minutes earlier).

On mine, the lag occurs when plugged in as well. I'll try the slider setting the next time it happens when on battery, so thanks for the idea.

Hopefully, Microsoft will resolve this issue so we don't have to resort to such things to get what should be normal performance out of these $2500+ machines. 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Yeah... laggy mouse with a $3200 laptop is pretty ****.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have the same problem.

I expected near perfection from a $3200 laptop and I did not receive it.

This happens both when I'm using the dock and when I'm not using the dock, when I'm plugged into AC and when I'm using the battery.

Is there any workaround besides installing Ubuntu?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

https://github.com/jakeday/linux-surface

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I  have found that turning off the "Pinch to Zoom" feature in the Trackpad settings helps.  It's not perfect, but it's better.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I  have found that turning off the "Pinch to Zoom" feature in the Trackpad settings helps.  It's not perfect, but it's better.
Thanks for the idea. I did try that, and it didn't seem to make a difference.

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.