How to change system locale in Windows 10 - The Language for non-Unicode programs and Change system locale feature is unavailable in Windows 10 Region and Language options page

I have an English/Dutch/French Windows 8.1 PC. After upgrading to Windows 10, I attempted to change system locale to Chinese (Simplified, China) in order to make non-unicode programs diaplay Chinese. I was hoping to follow the approach similar to that of Windows 8.1 (see below):

  1. Open Region and Language by clicking the Start button , clicking Control Panel, clicking Clock, Language, and Region, and then clicking Region and Language.

  2. Click the Administrative tab, and then, under Language for non-Unicode programs, click Change system locale If you're prompted for an administrator password or confirmation, type the password or provide confirmation.

But the above approach is no longer possible in Windows 10. The deepest level of menu I could go is to set Chinese as "Primary" system language. This renders menu in all my Chinese applications failing to display Chinese characters. 

I had to revert to Windows 8.1, which was possible within one month of upgrading to Windows 10. Hope Microsoft will resolve this issue in Windows 10 within a year, otherwise I will never be able to upgrade to Windows 10 within the free upgrade period. 

Please advise if I had overlooked Windows 10 feature after all.

 

Question Info


Last updated November 16, 2019 Views 118,993 Applies to:
Answer
Answer
You don't change the system locale to change the interface language. You do that in Settings>Time & Language>Region & language. Put the language you want at the top of the language list here and make sure you download the language pack for it.
"No matter where you are, everyone is connected"

16 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.