Surface Pro - No Wireless Networks

(NOW RESOLVED)

I've had my Surface Pro for about a week and haven't had any problems with network connectivitiy until a few hours ago. It is not picking up any wireless networks although it is clearly in range and the network is clearly working on other machines.

When I troubleshoot the problem, it says that there is a problem with the driver for the Ethernet adapter, though the Pro doesn't have an ethernet jack.

Airplane mode is turned off.

When I go to Network and Sharing Center and click Set Up A Network, both options "Connect to the Internet" and "Set up a new network" do not work. The latter brings up a box that asks me to "Choose the wireless router or access point you want to configure" and although I wait for longer than 90 seconds, nothing appears.

EDIT: Okay, I think I found the problem. In my PC Settings in the Wireless tab, the "Wireless devices" and "Bluetooth" switch is turned off. The problem now is that when I try to turn that on, it'll go through a little loading period and flip back off. I'm not sure how to turn this on for good.

EDIT 2: I fixed this problem by opening the Device Manager, expanding the Network Adapters tab, double clicking the wireless adapter and disabling then enabling it.
|
Answer
Answer
(NOW RESOLVED)

I've had my Surface Pro for about a week and haven't had any problems with network connectivitiy until a few hours ago. It is not picking up any wireless networks although it is clearly in range and the network is clearly working on other machines.

When I troubleshoot the problem, it says that there is a problem with the driver for the Ethernet adapter, though the Pro doesn't have an ethernet jack.

Airplane mode is turned off.

When I go to Network and Sharing Center and click Set Up A Network, both options "Connect to the Internet" and "Set up a new network" do not work. The latter brings up a box that asks me to "Choose the wireless router or access point you want to configure" and although I wait for longer than 90 seconds, nothing appears.

EDIT: Okay, I think I found the problem. In my PC Settings in the Wireless tab, the "Wireless devices" and "Bluetooth" switch is turned off. The problem now is that when I try to turn that on, it'll go through a little loading period and flip back off. I'm not sure how to turn this on for good.

EDIT 2: I fixed this problem by opening the Device Manager, expanding the Network Adapters tab, double clicking the wireless adapter and disabling then enabling it.

Followed Instruction @ Edit2: 

At device manager found Marvell Avastar Wireless Composite Device.  Disable(d) it. Did not see an Enable option.   So, I chose update driver.  That worked.

Gracias.

46 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Answer
Answer

Hello KerryBarret and everyone,

I'm glad to jump and help. Please take a look at this article.

Let us know.

Cheers,

Reagan_L

11 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated April 5, 2021 Views 52,818 Applies to: