Question

Q: Surface Pro 4 Jul 2017 Update - Type Cover not working

I updated the latest update Jul 2017 and it bricks my type cover completely. Tried everthing, from reset, volume + and power, everthing including cleaning etc. 

I just do not understand. When I did Apr 2017 update, it also half bricked it, but at least using volume+ and power helps, but now totally unusable. 

If anyone come across, this, please help.

**The thread is moved to the cover category.**

Answer

A:

Hi Leo,

This issue can be caused by both the software/firmware and the hardware. You can refer to this article on how to troubleshoot your Surface Type Cover.

However, if you have already tried all possible resolution and still the keyboard doesn't work, we suggest that you visit a nearby Microsoft Store and have your Surface device and Type Cover assessed. If you're outside the US, get in touch with Microsoft Customer Support in your region. Please refer to the Global Customer Service phone numbers.

Feel free to post back if you need assistance.

Did this solve your problem?

Sorry this didn't help.

4 people were helped by this reply



 
Question Info

Views: 8,771 Last updated: June 21, 2018 Applies to: