Surface Pro 4 Jul 2017 Update - Type Cover not working

I updated the latest update Jul 2017 and it bricks my type cover completely. Tried everthing, from reset, volume + and power, everthing including cleaning etc. 

I just do not understand. When I did Apr 2017 update, it also half bricked it, but at least using volume+ and power helps, but now totally unusable. 

If anyone come across, this, please help.

**The thread is moved to the cover category.**

 

Question Info


Last updated June 22, 2019 Views 14,933 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

After a disappointing trip to Microsoft Store, and also tried online troubleshooting with a remote Microsoft technician. After a week they told me they have tried all solutions and none of them works. They suggested me to pay money for a replacement. Yes, Surface 6 is out and they ask me to pay money to replace a Surface 4. I remember the Microsoft Store representative also told me so and the price for replacement is something like $400 or $500? Seems like Microsoft does not have internet access to eBay and they believe their customers don't have either.

I guarantee this is the last Surface product I bought. I will persuade all my friends and relatives to not buy any Surface or even Microsoft product.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi everyone,

This is exactly my problem. As of October 21st 2018 the Type Cover on my surface pro 3 (both out of warranty, as the chat helper was quick to point out...) stopped working completely. I tried everything. I did the power and volume button reboots, reinstalled drivers, reset the whole tablet twice, cleaned the contact pads Nintendo cartridge style, nothing. My Device Manager displays two HID Keyboard Devices, and nothing will make it recognise the Type Cover.

I noticed over a number of days that the Type Cover would randomly work or not work, which completely perplexed me, and I have finally figured out that it works when the Surface has drained the battery completely and needs to be plugged in to turn on again. If I plug it all in and start, the Type cover works. However, if I turn it off, and then turn on again with the remaining battery, the Type Cover will no longer be recognised.

It's a right pain in the ass and Microsoft has done nothing about it.

**UPDATE AS OF NOVEMBER 11**

There was some sort of update two days ago. The Type Cover now does not work at all. It doesn't matter if I reboot from a dead battery. Device Manager now displays only one HID Keyboard Device instead of the Type Cover, but really...what difference does that make?

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have now raised this issue with the ACCC in Australia, and I'll keep pestering them until they investigate Microsoft's silence on the issue. In a couple of weeks, if I've heard nothing, I'll follow up with phone calls and a submission to the Office of Fair Trading.

My suggestion is, to anyone in Australia suffering the same issue, to do the same.

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Create an online petition?

4 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have spoken to the Office of Fair Trading in Australia. I would suggest, if you're in Australia and suffering with this Type Cover issue, to do the same.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Someone in Spain with the same issue, repaired or not? 

¿Alguien en espana con el mismo problema, soluconado o no?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi

In Portugal with one Surface Pro 4 with the type cover working sometimes and other SP4 without the type cover working.

All the type cover are working fine in one SP4.

The one that is not working was working before updates.

Tryed recovering, formatted with external image from MS, Tryed MS troubleshooter and 0.

I am writting here in this fórum for the second time. Another thread with same topic.

So much people with same problem.

MICROSOFT DON'T YOU READ THIS FORUMS ?

DON'T YOU HAVE SHAME ON SELLING A "PREMIUM" PRODUCT THAT AFTER THE UPDATE STOPPED WORKING CORRECTLY ?

When i brake something i assume my fault when are you MS starting to behave like you should.

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

https://www.change.org/p/microsoft-microsoft-to-take-responsibility-for-dead-surface-type-covers?recruiter=852120244&utm_source=share_petition&utm_medium=copylink&utm_campaign=share_petition

Hi there, I had created a petition in the hope that many like me who had dead type covers of no fault of us, can show through the petition, our frustration and exasperation with thr situation, hoping that Microsoft can be moved into taking a positive step towards solving this issue. 

Regards

Alan (Singapore)

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

DON'T MS THINK IT'S TIME TO FIX THIS ANNOYING PROBLEM???????????????

IF MS HAS PROBLEMS THEY SHOULD FIX IT ASAP. I PAYED FOR A PRODUCT THAT IS BROKEN BECAUSE OF THEM. THIS IS NOTHING BUT RIDICULOUS HAVING A TREAD THIS LONG WITH NOTHING BUT PROBLEMS.... 

Impressive.... so many reports on this same subject....

I have a SP4 with a cover that stopped working with the update back in 2017, long story short.

Reboot, reboot with 2 buttons, reinstall drivers, reinstall windows.... etc... Nothing did the trick.

called MS service center and my warranty was finished 2 months before that, so nothing they could do or wanted to do. They "kindly suggested" to get another cover from them, but with shipping and everything wasn't worth it, ended up buying one in a store that I returned same day because the problem was not the cover, obviously.

My cover is working well, I tried it on another SP4 and it works great.

I have being reading this tread for a will and it's just ridiculous the all situation, I was a happy costumer that payed a little fortune for a product, however I'm not happy anymore and when someone asks me about the SP, my answer is very easy "don't buy one" and MS lost at least 11 sales this past year or year and half (just from people I knew were buying or about to buy one).

I Saw somewhere today that a huge update was released and it was supposed to fix it, tried and the only thing that came out of that was wasting 2 more hours trying to fix something that shouldn't be broken in the first place.

I bought my unit back in Portugal almost 3 years ago (or so) for approximately 2,000 CAD, moved last year to Canada a few months before the problem. For something this expensive it should work. If I paid that kind of money for a computer I shouldn't need to buy another Bluetooth keyboard to be able to right on my SP4.

If someone has suggestions or know a way to fix this covers please speak. 

If someone from MS read this tread.... Guys stop partying around it's time to fix this annoying issue, I take my SP everywhere, before this was easy 1 small and nice package, now is a small package with a keyboard and a mouse, is worse than a laptop.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I was given an option of making an exchange at a price of SGD$638. I find it ridiculous. >_<

In lieu of the current situation, I have started a petition. I hope Microsoft can take notice and respond immediately to this issue. Pls support and hopefully we csn exert some form of media pressure on Microsoft to take actuon. 😡

https://www.change.org/p/microsoft-microsoft-to-take-responsibility-for-dead-surface-type-covers

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.