Surface 3 - Wireless Display Media Viewer stuck on installation after getting Creators Update

I updated to the Creator's Update today, and now I've got a half-installed (?) app called "Wireless Display Media Viewer" stuck on my apps list. It looks like it's stuck in installation purgatory, and when I click on it, it just opens a blank black window. There is no option to uninstall, and a Microsoft tech actually tried to uninstall it through PowerShell with no success. Has this happened to anyone else?

***Post moved by the moderator to the appropriate forum category.***

***Subject edited for clarity by the moderator.***

Answer
Answer

The problem was already solved. It took a system reset to do the trick. The device is a Surface 3, and it was fully up to date, so I don't think it was a driver. I wish I knew what the real problem was, because it's a pain in the butt remembering what was installed and all that stuff after a reset.

For more info see https://answers.microsoft.com/en-us/windows/forum/windows_10-start/what-is-the-wireless-display-media-viewer/3714e048-9bb3-440b-934d-01a3c4b3699c

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

 
 

Question Info


Last updated October 11, 2019 Views 4,580 Applies to: