After last patch tuesday (3/11/2014): Surface not going into connected standby when TypeCover is attached

Hello,

ever since I installed last patch tuesday's updates my S2 has a major bug when the TypeCover is attached. Basically the title says it all. The thing won't go into connected standby anymore. Detaching the Cover "fixes" the problem but that is no satisfying solution, obviously. The problem is reproducable and not a "once in a while" thing...it happens all the time and results in a battery drain even when not using the S2 actively.

I'm not alone with this as can be seen over at WPCentral's Forum, where we are discussing the problem: http://forums.wpcentral.com/microsoft-surface-2/269245-fix-wake-issue-not-working.html#post2405630

Help?

Thanks!

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hello,

ever since I installed last patch tuesday's updates my S2 has a major bug when the TypeCover is attached. Basically the title says it all. The thing won't go into connected standby anymore. Detaching the Cover "fixes" the problem but that is no satisfying solution, obviously. The problem is reproducable and not a "once in a while" thing...it happens all the time and results in a battery drain even when not using the S2 actively.

I'm not alone with this as can be seen over at WPCentral's Forum, where we are discussing the problem: http://forums.wpcentral.com/microsoft-surface-2/269245-fix-wake-issue-not-working.html#post2405630

Help?

Thanks!

Just want to corroborate this as I am also seeing a high battery drain with my Type Cover 2 attached  when in standby. A respectable 1% per hour drain DETATCHED versus 7/10% per hour when ATTATCHED. This was NOT present before the last round of FW updates. The device also remains 'warm' when in standby with cover attached, indicating something is running that should not be. Please fix!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

This is also happening to me, but it's not that the Surface is not going into connected standby -- check your event viewer and I am sure it will say that it is. The Surface does go into standby, but then at some point it exits standby and then stays on -- draining battery etc.

I believe this is related to a new error that I see in my event viewer since this update, which is "Event 264, Win32k, A multi-touch device reported inconsistent contact information." Basically, it sounds like the Surface thinks it is being touched, turns on, and then fails to turn back off.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

This is also happening to me, but it's not that the Surface is not going into connected standby -- check your event viewer and I am sure it will say that it is. The Surface does go into standby, but then at some point it exits standby and then stays on -- draining battery etc.

I believe this is related to a new error that I see in my event viewer since this update, which is "Event 264, Win32k, A multi-touch device reported inconsistent contact information." Basically, it sounds like the Surface thinks it is being touched, turns on, and then fails to turn back off.

Well I tested the behaviour many times. I would attach the cover, press the power button to switch the display off, close the cover and then let the S2 sit for two hours. The result was always the same: when I opnened the cover after two hours the screen was already on (no, I don't mean that it turned on, it already was on and it didn't show the lockscreen as it usually would). Then I used the batteryreport command to check how long it had been in the active state. It's always the full two hours (+/- a few minutes obviously). So yea, you might be right with your assumptions...I think your statement sounds very conclusive. I don't know if it enters connected standby just to leave it again a few minutes later. But in the end it's active pretty much the whole time. The whole "multi-touch device reported inconsistent contact information" might very well Point towards the cover....

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I had my cover closed and heard the mail chime go off which I had never heard previously with the cover the cover closed. I think it is related but not sure. The battery was quite low when I checked the device and yes like the other poster it did appear to be already on. Maybe sorta reverse-placebo effect though.... Maybe coincidental and after reading the bug post thought it was related         

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I think this is related to my issues too.  The touch cover is causing battery drain and/or refusing to let my Surface 2 go to sleep.

I also get another problem since the last patch with the device constantly thinking the top left corner of the screen is being tapped.

If I remove the cover, and restart the machine, it runs as well as it ever did.

So now I have a surface with no cover :(

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Same here, I work at a school that has deployed out 105 Surface 2 and 105 Type Cover 2 keyboards.

We handed out the Surface 2 first then about a week later the keyboards. Nothing but trouble since.

Students reporting battery drain, the camera comes on sometimes while the Surface is it's case, and of course, overheating!

Trying to work with Surface/Microsoft support for IT professionals, and they just want to do a straight warranty swap over which I'm trying to avoid with 105 Surfaces! 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Im also having problems with this, and every time I open the cover to wake up the surface 2, I cant enter my passcode, as the keyboard doesn't seem to work, I have to sign in with the touch screen keyboard, detach the type cover 2, then re attach it, and only then it might, might work.

was extremely happy before last update. now I just feel like I made mistake.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

i am sure microsoft is working on fixing this by either tomorrow "patch tuesday" or next week.  I hope it doesn't take longer than that

I assuming it has something to do with the powercover firmware update. Is there anyway to revert that given I'm never going to get a powercover?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

i am sure microsoft is working on fixing this by either tomorrow "patch tuesday" or next week.  I hope it doesn't take longer than that

I assuming it has something to do with the powercover firmware update. Is there anyway to revert that given I'm never going to get a powercover?

You mean the patch Tuesday of last week ?  lets hope they do this week or else well have to wait for a longer time 😉

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I've also noticed that when I cause the device to sleep, the backlit keyboard on Type Cover 2 stays lit / lights on.

To M.T., the patches seem to only come on Tuesdays, tomorrow is tuesday

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

 
 

Question Info


Last updated May 18, 2018 Views 1,958 Applies to: