Surface Pro 4 type cover suddenly not working.

I don't know what happened. I turned my Surface Pro 4 on the other day and the type cover is dead. No lights. No response. No indication that it's working at all.  I rarely take my surface anywhere. 

This started on July 9th 2018. My system information is below. I've gone through all of the steps in the "Troubleshoot your Surface Type Cover or keyboard" page. I've tried to manually download and install the latest firmware and drivers from the "Download firmware and drivers for surface" page. I picked SurfacePro4_Win10_16299_1801701_1.msi. My device manager does not show the "Surface Touch Cover Filter Device" under keyboards or anywhere. It only shows the HID keyboard and cannot detect my type cover. The type cover is completely unresponsive. Also, my windows updates are completely up to date. I've provided the links to the troubleshooting pages I used below.

AGAIN, WTH

Troubleshoot your Surface Type Cover or keyboard

Download drivers and firmware for Surface 

Edition
Windows 10 Professional
Version
1803
OS Build
10.0.17134.165
Serial #
035060755053
Processor
Intel(R) Core(TM) i5-6300U CPU @ 2.40GHz
Graphics card
Intel(R) HD Graphics 520
System
OSType64BitX64
RAM
8 GB

 

Question Info


Last updated September 19, 2019 Views 24,197 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi E_C_H_O,

You can boot into the Surface UEFI to check if the Type Cover will be responsive. To boot into the UEFI, refer to this page. If it does not work in the UEFI, then it means that what you're having is a hardware problem. I would recommend that you take the device to a Microsoft Store or contact Microsoft Support for assistance.

If the Type Cover works in the UEFI, then the problem is related to the software. Please run the Surface Diagnostic Toolkit to check for any errors. To download the tool, open this link.

In case you need further assistance, please reply to this post.

Regards.

3 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Type cover is still dead/unresponsive in UEFI. The Diagnostic tool found and did nothing. I also disagree with your assessment. A hardware problem implies something PHYSICALLY wrong. My SP4 hasn't left my dock in weeks. Also, without the correct drivers, the type cover is unable to communicate with the Surface. The reason I believe this is because I had a windows app that could execute commands by mutli-point touch and swipes. That app is also suddenly not working. 

I did a full windows reset last night and that did nothing. SO DO NOT DO A WINDOWS RESET TO FIX THIS PROBLEM!!!! DO NOT!! IT WILL NOT FIX YOUR PROBLEM!!! It will just add to your headache. This product has been nothing but a headache since the day I got it. 

10 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hardware issues can be physical damages or whole equipments/devices being faulty. Since the Surface did not recognize the Type Cover after performing a reset, let's check for physical connection issues. Try to disconnect the Type Cover and wipe the connectors using a clean, soft cloth. After doing that, reconnect it to the Surface. Do this 3 times and see if the Surface will recognize the Type Cover.

I'll be waiting for your update.

3 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

There are unfortunately many people with this issue (including a neighbor and a
friend). For most, the problem occurs after some random Windows Update. My
theory is that it isn't a particular update, but something in the update PROCESS
that corrupts the firmware somehow. Microsoft has not commented on this, nor
have they come up with a fix. If it does not work in the UEFI, no amount of
reimaging will fix it. Cleaning the contacts has not fixed this for anyone.
 
 
See
and other threads
 
Your only solution is to spend $450US for an out of warranty refurb exchange.
 
 
 
Barb
My Blog - http://digitalmediaphile.com/
MVP-Windows and Devices for IT
Windows Insider MVP

5 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Dear Ruz_San,

There are dozen of people complaining about this issue and all you can suggest is to clean the connectors? How about you provide some evidence that Microsoft did actually something about this April windows update? I had no issues with my surface pro 4 device until the windows update. To date after hours spent fixing the problem, I still can't use the type cover . Yet every engineer is suggesting to wipe clean the connectors. What a joke!! 

11 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

So, I basically have a $150 useless cover and need to give Microsoft $450 because they broke my cover. There is also no indication that Microsoft knows what the problem is or intends to fix the problem so the same thing could happen again. I think I'm done with Microsoft hardware.

11 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Yup, you've nailed the current situation
 
>There is also no indication that Microsoft knows what the problem is or intends to fix the problem so the same thing could happen again.
 
You can also investigate 3rd party type covers that use Bluetooth like
(one of these is for SP4, the others are for Surface 3). I have no firsthand
experience with these but Amazon has a good return policy.
 
 
Barb
My Blog - http://digitalmediaphile.com/
MVP-Windows and Devices for IT
Windows Insider MVP

3 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Having the exact same problem - happened after the last major update.  A co-worker who went through the same issue a few months ago did a clean install which didn't solve the problem. 

I spent the greater part of this last weekend doing the same useless troubleshooting (pressing power/volume buttons, system restore, system reset, uninstalling updates, re-installing drivers, cleaning connections).

Really disappointed, Microsoft.   It would go an incredibly long way to at least announce/admit there is a widespread issue with Surface Pro keyboards being bricked by some software/firmware update.  Knowing that a fix is possibly in the works would be encouraging to most folks.  Staying silent on the issue will drive customers away.


10 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have the same problem. In my opinion, the problem should come from firmware updating. I red the same problem, and the troubleshooting of this problem https://answers.microsoft.com/en-us/surface/forum/surfpro3-surfupdate/surface-pro-3-type-cover-not-working-in-biosuefi/b923c993-c055-4893-a834-04d077d02069 , but I still don't try it yet.

7 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I called to Microsoft surface in Thailand, and they said the problem should be the hardware problem. So, they said I have to pay 450$(in approximately 16,000 baht) because mine was out of warranty. So, I decided to use wireless keyboard(Logitech MK240), it work fine for me. I think Microsoft should response for this problem. My surface pro 4 just 2 years, I use it a few hour, and the problem come after UEFI updating.

13 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.