surface dock ethernet speed

I have a surface pro 4, 8/256. I pay for 200mps internet. If I connect the ethernet to the dock I get about 40. If use wifi I get 200. The Spectrum technician came yesterday and gave me all new equipment but it didn't help. He said it was the dock slowing the spee. Is this true? Or is there a fix? 

Hello Andrew,

Let us help you check the credibility of your Surface Dock. We need to perform several steps to resolve the slow internet connection on your Surface Pro 4 when hard wired to the Surface Dock. We recommend that you download and run the Surface Diagnostic Toolkit then restart the Surface was done. After restarting, kindly update the Surface Dock using the Surface Dock Updater tool to ensure the Dock has the latest firmware available.

Here's how to get the Surface Dock Updater tool

  1. Go to Download Surface Tools for IT.
     

    Note

    You don't need to download the entire software package. When you select Download, select the Surface Dock updater by itself.

  2. Select Download.

  3. Under Choose the down load you want, select Surface_Dock_Updater_v2.7.136.0.msi (or later).

  4. Select Next and follow the rest of the instructions to install the tool.

Now that you’ve installed it, you can use the Surface Dock Updater tool to update your Surface Dock. Connect your Surface Dock to your Surface, open the tool, and select Start. Then follow the onscreen instructions.

Please note that you’ll be asked to disconnect and reconnect your Surface Dock during the update. After you’ve disconnected the Surface Dock, it’ll need to stay powered on for at least 3 minutes for the update to install. The LED light on the Ethernet port of the Dock will blink while the update is happening. Wait until it stops blinking before you unplug your Surface Dock from its power.

If the Surface Dock didn’t update with the Updater tool, try these same steps with another Surface device running Windows 10 Pro. Or, you can get your Surface Dock updated free of charge at a Microsoft Store near you.

Let us know if your need further assistance and we'll get back to you as soon as we can.

Thank you.

2 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I, too, have this same issue.  Wired ethernet and cannot get more than about 350 mbit.  Previously it has worked just fine with symmetrical speeds of about 900mbit. A recent update has svrewed something up. I have updated dock and all drivers.  No change.  My desktop plugged into same switch sees full speed.  I have switched ports on switch, connected directly to ATT router and same results of 350 mbit every time.  Appears to be a Surface Pro 4 firmware issue with the Marvell driver?

7 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I, too, have this same issue.  Wired ethernet and cannot get more than about 350 mbit.  Previously it has worked just fine with symmetrical speeds of about 900mbit. A recent update has svrewed something up. I have updated dock and all drivers.  No change.  My desktop plugged into same switch sees full speed.  I have switched ports on switch, connected directly to ATT router and same results of 350 mbit every time.  Appears to be a Surface Pro 4 firmware issue with the Marvell driver?

I am experienceinh the same issue with a surface book and the dock. 

I have reloaded the os to bo avail.

if i do a safe boot, i get full bandwidth. 

Have complained heavily to MS and they arent much help. 

4 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I have the same issue with my Surface Book connected to the docking station. With WFI the network speed is about 200mbs. With wired internet the speed drops to 60 mbs while I have a 500 mbs internet connection.

When is look at the properties of the the ethernet adapter is says its a 1 Gbs connection.

I tried the Surface Diagnostic Analyzer and updated the firmware vof the docking station. No result. Wired speed stays low.

I also tried another laptop on the same cable and this gave a sped of 500 mbs. So the cables are ok.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I was able to determine (as did Microsoft) that my dock became defective.  Very strange occurrence.  I started off going to the Microsoft Store to get assistance, but they told me to pound sand.  Completely worthless and gave me little hope of resolution.  I purchased my dock on Amazon.  I was within the 1 year limited warranty period and even had a copy of my receipt.   I figured I would try to call the 800 Microsoft number and see if they could help me.  After the fairly lengthy calls (yes, many calls over several days and yes my awesome support agent called me back) and running all the diagnostics/updates (that I had already done and determined the issue was the dock) the EXTREMELY nice young lady at Microsoft support told me they would be replacing my dock free of charge.  During the testing we did notice that the USB was also acting up and was likely related.  Not only was the dock's ethernet port only running at about 300-350mbps, but I was also getting random "USB Device Not Recognized" errors with no USB devices plugged into my dock or Surface Pro.  

I am very happy to report that I did indeed get a brand new dock 2-day aired to me and all the mysterious errors are no longer present.  

I even received a follow-up phone call from my support agent to ask how everything was working.  She went above and beyond.  She was in Nicaragua and helped me plan a trip there with some must-see places to visit for my wife and I.  I hope others have this great experience with their phone support.  It is a lost art. 

2 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

WOW - that is great news - especially since I have changed out everything but the dock itself to no avail.

Your dock issues sound spot-on to what mine are. I will call MS and see what they say about replacing the dock.

I will update everyone as soon as I know anything.

Thank you  - and good luck with your trip.

JT

2 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated February 13, 2021 Views 8,300 Applies to: