Pro X won't stay in sleep for more than a few hours.

If I put my Pro X to sleep, say by closing the cover or pressing the power button, then come back to it more than a few hours later, it will take some time to wake up as it resumes from hibernation.

I've use powercfg /sleepstudy and can see that the cause is always hibernation due to power budget being exceeded.  It's used more than 5% of the battery in sleep over 3-4 hours.  It's always the Qualcomm modem that's listed as being responsible.

I don't have a SIM yet, and have tried turning off Mobile data and even disabling the modem device in device manager.  But it's still doing it.

Do other peoples Pro X's sleep overnight and still instantly turn on? (I know the default hibernate timer is set to 18 hours, I'm talking about <10 hours overnight).

AFAIK I have all the latest updates, including the firmware update from a few days ago.

 

Question Info


Last updated March 25, 2020 Views 253 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hello DavidN,

                                                                                                                                                                                                                                           

Thank you for reaching out Microsoft Community. Even if the Surface is in Sleep Mode it will still consume battery life due to apps open in the background. We highly recommend that you shut down the device properly specialy overnight to consume power. For waking up the Surface that takes time, try to do a force shutdown. Performing this is like removing the battery from a laptop or unplugging a desktop PC. It resets the hardware and clears all the cache and memory for your hardware. 

  • Press and hold the power button until the screen turns off (about 10 seconds), then release the power button.
  • Press and release the power button to turn your Surface back on. You should see the Microsoft logo.
  • If that doesn't work, here's how to make sure your Surface turns off completely:

    Press and hold down the power button until your Surface restarts and you see the Windows logo screen (about 20 seconds), then release the power button.

  •  

    Observe the Surface and let us know if there is an improvement.

                                                                                                                      

    Regards,                                                                                                                 

    KarenJune_F

    Did this solve your problem?

    Sorry this didn't help.

    Great! Thanks for marking this as the answer.

    How satisfied are you with this reply?

    Thanks for your feedback, it helps us improve the site.

    How satisfied are you with this response?

    Thanks for your feedback.

    Hi DavidN,

    I am having the exact same problem. Just to compare, I also have the HP Envy X2 (Snapdragon ARM model) which I can leave with the lid closed for two weeks or more and it will "instant on" immediately, and only drop a few percentages in battery life all the while. However, with the X, after only a couple of hours it goes into a state where I need to press the power button and wait for it to resume. 

    The settings are exactly the same on both machines...

    I have called support twice and they have been useless, (if there was a word for 'less' than useless I would use it!) no matter how I explained the situation they had no idea what I was talking about - seriously Microsoft, you guys need to sort that stuff out!

    The X is claimed to be capable of "instant on" but something is not working properly as far as I can see, and I have another ARM machine to compare it to.

    Any help is much appreciated.

    Did this solve your problem?

    Sorry this didn't help.

    Great! Thanks for marking this as the answer.

    How satisfied are you with this reply?

    Thanks for your feedback, it helps us improve the site.

    How satisfied are you with this response?

    Thanks for your feedback.

    I have the same issue as well, did you ever find a solution?

    Did this solve your problem?

    Sorry this didn't help.

    Great! Thanks for marking this as the answer.

    How satisfied are you with this reply?

    Thanks for your feedback, it helps us improve the site.

    How satisfied are you with this response?

    Thanks for your feedback.

    I tried the 20 second full reset procedure and then have been monitoring the sleep performance since then.

    There doesn't seem to be an improvement, the device still cannot sleep for very long before the battery drain is so great that it switches to hibernate instead.  One of the key reasons for switching to an ARM based system is of course the bettery battery performance and instant on ability so it's not really living up to that yet!

    This is an example from the sleep study report or a typical modern standby session.  It is ALWAYS the Modem subsystem of the SOC (SQ1 chip) that is shown as the largest consumer of power with a lot of active time while the device is asleep.  I don't have a SIM installed so it probably shouldn't be spending any power on the modem anyway.

    Did this solve your problem?

    Sorry this didn't help.

    Great! Thanks for marking this as the answer.

    How satisfied are you with this reply?

    Thanks for your feedback, it helps us improve the site.

    How satisfied are you with this response?

    Thanks for your feedback.

    I have the same issue, do you happen to have roaming on for your modem?  I turned it off and will put it to sleep for around 16 hours.  Will post results at the end of that time.

    Did this solve your problem?

    Sorry this didn't help.

    Great! Thanks for marking this as the answer.

    How satisfied are you with this reply?

    Thanks for your feedback, it helps us improve the site.

    How satisfied are you with this response?

    Thanks for your feedback.

    defo have the same issue.

    SPX will go into hibernation and no instant on. Have to power up using the power button.

    Did this solve your problem?

    Sorry this didn't help.

    Great! Thanks for marking this as the answer.

    How satisfied are you with this reply?

    Thanks for your feedback, it helps us improve the site.

    How satisfied are you with this response?

    Thanks for your feedback.

    No, as I mentioned I have no SIM or anything. I am only using it with Wi-Fi.  I have tried it in flight mode to turn off all the radios, that made no difference either.

    Did this solve your problem?

    Sorry this didn't help.

    Great! Thanks for marking this as the answer.

    How satisfied are you with this reply?

    Thanks for your feedback, it helps us improve the site.

    How satisfied are you with this response?

    Thanks for your feedback.

    I'm seeing the same behavior. I have an LTE SIM installed, roaming is off.

    This is probably related to the other thread I posted about display brightness. That problem only occurs after hibernate.

    Did this solve your problem?

    Sorry this didn't help.

    Great! Thanks for marking this as the answer.

    How satisfied are you with this reply?

    Thanks for your feedback, it helps us improve the site.

    How satisfied are you with this response?

    Thanks for your feedback.

    Looking into this further, for me the below temp work around works as i do not currently require the LTE. 

    Just by turning cellular modem off, the issue is still present. You have to physically disable the modem interface under Network Connections. 

    Having disabled and tested this, i can confirm, after 10hrs of "standby" the instant on works as normal or by tapping any of the keys on the keyboard. 

    Settings - Network & Internet - Change adapter options - Right Click and disable Mobile interface. 

    Obviously for those requiring the LTE will have to wait until MS resolves this issue.

     

    With this in place, I am getting 10hrs - 2% battery drain + Instant On


    Did this solve your problem?

    Sorry this didn't help.

    Great! Thanks for marking this as the answer.

    How satisfied are you with this reply?

    Thanks for your feedback, it helps us improve the site.

    How satisfied are you with this response?

    Thanks for your feedback.

    Thanks,  I thought I'd tried that one and disabling it in device manager too but I'll certainly give it another go as you describe.

    Did this solve your problem?

    Sorry this didn't help.

    Great! Thanks for marking this as the answer.

    How satisfied are you with this reply?

    Thanks for your feedback, it helps us improve the site.

    How satisfied are you with this response?

    Thanks for your feedback.

    * Please try a lower page number.

    * Please enter only numbers.

    * Please try a lower page number.

    * Please enter only numbers.