.docx filetypes can not be associated with LibreOffice from MS Store?

My Surface Pro 4 has a little space left in the hard drive and so I replaced some of the installed programs with apps from MS app Store.

Problem is, although I like LibreOffice to open and edit all .docx files, unfortunately, it doesn't come as an option when setting default apps making it impossible to associate .docx files with the app.

Any help?

 

Question Info


Last updated July 21, 2019 Views 38 Applies to:

The Libre Office app from the store appears to be an unofficial repackage, and not the full suite from the Libre Office developers, I would be concerned that this may have gimped functionality and recommend deleting this and installing the official suite from 

https://www.libreoffice.org/download/download/

Right click a document, in the menu at the bottom is properties setting, select change.

If LibreOffice isn't there you will have to navigate to the executable using the 'browse' function offered. The LibreOffice directory containing the executable can be found at C:/ProgramFiles(x86) or C:/ProgramFiles, (unless you installed it elsewhere specifically during install). Find the libreOffice.exe and select that as the default application to open the docx.

You can also probablyassociate the docx with LibreOffice in LibreOffice settings, I don't have it installed so I can only point you to this web article that sets it all out.

https://www.howtogeek.com/281166/how-to-change-the-default-file-format-in-libreoffice/

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I don't think you read the issue properly.

I downloaded the app from Microsoft Store thus it's impossible to find it inside the directories you mentioned.

Also, the program you referring to it's a bit heavier.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

First, uninstall that "app" and go to http://www.libreoffice.org and download the full program.  While on the download page, at the top, there is a "Help" file you will need to download as well.

You will also need to install JAVA to run along with it (http://www.java.com) and you will see a warning regarding Windows 10 and the Edge browser but ignore it.

After installation, the system will still default to Microsoft Office (if you have it installed) for the file associations.  Find a ".docx" file on your computer and right click on it and tell it to open with LibreOffice and there should be a tag you can set to set it as default.

You may still have issues with that even after changing it.  Under Settings in Windows 10, you can look around for "Default Apps" and select LibreOffice instead of Microsoft Office.

It can be difficult to change file associations in Windows 10 but eventually works.

James R. Vinyard

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Oh, by the way, the remove the "App", right click on the menu for a text menu and select "Apps & Features".  You can remove it from there.  For file associations; that is located under Settings/System/Apps and at the bottom of the right side panel, you can select the associations for apps not listed.
James R. Vinyard

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Web apps from the store are conveniently (sarcasm) installed into a hidden folder, something like

C:\Windows\program files\%WindowsApps%

note the directory specified inside %dir%, a hidden directory (even setting files explorer to show 'hidden files' does not allow access without UAC intervention.

This makes if tough to navigate inside wizards.

I simplified the solution, just as James Vinyard has, because if you are a user at the level who is unable or unwilling to use his brain to search for the solution using rather simple Internet search tools, you need hand holding.

Your rude attitude does not endear yourself to me, and frankly what ever you think you know, you seem to have no idea of how much you do not know! I have a respect for the size of the knowledge hole that exists inside myself as far as a 'complete' grasp of everything the world of computation presents. 

Show some respect and humility when you ask for help. The rest of us do !

As far as Libre Office being 'heavier' I have run this on a 10 year old Thinkpad with a mere 8GB Ram and rudimentary Graphics chip and it runs like a charm, if the suite is too big for disk space you can choose which applications to want or not want during the install.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hey domcarter

I'm so sorry you got it that way, I didn't intend to offend you! I really appreciate yours and any other guy's time to help me out but definitely, I didn't intend to be an a**hole.

The directory (C:\Windows\program files\%WindowsApps%) you provided me with was the key to solve the issue without having to download the suite. All I needed was to change the ownership (and permissions) of "C:\Program Files\WindowsApps\42109FactoriaDatacenter.LibreOffice_6.2.2.0_neutral__zaf1c6h4vqsbt\VFS\ProgramFilesX64\LibreOffice\program" directory and then "look for another app on this PC" pointing to the same directory where the executables are contained.

My machine is a Surface Pro 4 that comes with 4GB RAM and 116GB physical memory.

Thanx to the Microsoft Store apps, I managed to save more than 30GB for my hard disk because I did the same for about 20 apps!

Plus, this issue can be a very useful future reference for other people.

I'm so very happy with the result!

Love & Peace

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.