Disabling Connected Standby on a Surface Book 2

Split from this thread.

Hi Dan,

Let's look into this Power configuration concern. You can disable Connected Standby via the Registry. We encourage that you Backup your Registry before proceeding with the changes. Navigate through the registry by expanding these Keysets: HKLM > System > CurrentControlSet > Control > Power > CsEnabled. Change the value from 1 to 0 and restart.

HKLM\System\CurrentControlSet\Control\Power\CsEnabled (1->0) (change from 1 to 0 and restart)

Update us if changing these values will rectify concern.

This thing kills the sleep mode at all on my Surface Book 2.

After this change, the "sleep" option is vanished from the power menu and from everywhere across the system. As a result, when closing the lid, Surface Book 2 always hibernates and it always takes ~2 minutes after opening the lid to boot up and connect to WiFi. This is bad...

|

Was this discussion helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this discussion?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this discussion?

Thanks for your feedback.

The question is WHY do you want to disable connected standby? What issue are you trying to resolve?
Barb
My Blog - http://digitalmediaphile.com/
MVP-Windows and Devices for IT
Windows Insider MVP

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

The question is WHY do you want to disable connected standby? What issue are you trying to resolve?
In my case (Surface Book 2) it’s a pure battery drain issue. Approximately 50% of times SB2 is literally “mining” something after I close the lid, draining the battery overnight or in my backpack. The surface itself becomes warm and hence I think it occasionaly does something when the lid is closed, which is bad as well.

25 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Microsoft supposedly fixed the hot bag issue with the original SB long ago - but
it looks like it might have resurfaced (bad pun)
I'd be interested if the strange fix a customer posted
difference in your case before proceeding further.
 
 
 
>In my case (Surface Book 2) it’s a pure battery drain issue. Approximately 50% of times SB2 is literally “mining” something after I close the lid, draining the battery overnight or in my backpack. The surface itself becomes warm and hence I think it occasionaly does something when the lid is closed, which is bad as well.
 
Barb
My Blog - http://digitalmediaphile.com/
MVP-Windows and Devices for IT
Windows Insider MVP

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

The question is WHY do you want to disable connected standby? What issue are you trying to resolve?

The battery of my sp4 was running faster than the cpu - I've read somewhere that disabling this feat will solve some of that issue.

I found the key they spoke of, in the register a while back. I disabled it and now... my sp4 doesn't need to recharge every hour or so again! (once a day will do it now)

Disable that key will improve the battery life significantly. 

30 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Discussion Info


Last updated July 27, 2021 Views 6,179 Applies to: