Skype locks up when *.btrll.com certificate is displayed

Hello,

 So far I haven't been able to make this happen, but over the past couple of weeks a warning about a certificate for *.btrll.com is displayed and afterward I cannot click on anything related to skype. I then have to kill skype using process explorer or Task manager.

This is acting like a virus or malware even though every scan i do returns no issue.

Is this related to the adware in skype??

Any suggestions on how to get rid of btrll would be greatly appreciated.

Thanks

Chris C

BTW - the selections subtopic and subject make no sense in regard to this issue. Since they are mandatory, I picked some messaging since that's what Skype does most for me.

Answer
Answer

This issue has been fixed for newer Skype versions. We would advise that you upgrade to the new Skype v8.x or the Skype UWP app v12.x all available from here.

The Skype classic version may continue to exhibit this issue.

Thanks for your patience whilst we worked to resolve this.

Babs

Skype Community Manager

If my reply provided you with a solution to your issue please mark my reply as a solution by clicking "Solved my problem" below.

3 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated January 30, 2021 Views 2,582 Applies to: