High CPU usage (around 30%) when update to Skype 7.37.0.103

Everyone, 
Recently, I got Skype Desktop version 8 update. I update to Skype v8 about 1 week. Although MS did not mention the issue is fixed by this release, but the issue is gone from my laptop.

====================

Last week, I tried to update skype to v7.38.x.xxx but seems still encounter this problem.

I have 3 laptops. Two had join the office network domain, one is in Windows 10 RS1 Enterprise edition and another is in Windows 10 RS2 Pro edition. These 2 systems encountered this issue when update to skype 7.37 or after. The other laptops in Windows 10 RS2 or RS1 Home edition, no matter which skype version in the system, did not encounter this issue never.

==========

When I upgrade Skype for Windows desktop 7.37.0.103, the CPU usage is occupied by skype and the CPU usage is around 30% always.

the previous version is 7.36.0.101 and the CPU usage usually, almost always stay in 0%.

Will a update version release soon to address this issue or where I can get skype 7.36 instead 7.37.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

In any Skype conversation window open the Smiley icon. Can you see the latest smiles downloaded?

 

1 person found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I was not aware the latest smiles when I encountered this issue. And No, I did not open any skype conversation window yet. just boot into Windows 10 and automatically log into my skype account then cpu usage raised.

today, I checked my another laptop with Windows 10 Home edition installed. I did encounter this issue.

This issue I reported was from my laptop for working and with Windows 10 Enterprise edition installed.

Do you think I need install skype 7.37 in my laptop with Windows 10 Enterprise edition installed again?
Any further suggestion?

1 person found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

There is something very wrong with Skype since yesterday night. I doesn't work on my home PC, my office PC and my phone. I have tried to update it, reinstall it... nothing works. It is using 30% of my CPU.

Most of the times Skype can't connect. When it connects - almost all my contacts are offline. I can't send any messages even when it is connected.

My colleagues have similar issues.

Does anyone else have such issues?

3 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Same stuff here: using 30%+ of CPU and cannot connect. 
“Real stupidity beats artificial intelligence every time.”
― Terry Pratchett, Hogfather

1 person found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Have the same problem here, and tried many things I saw on the internet.
I'm on HP probook 650 G1, Win 10 64b, Skype version 7.37.0.103 too.

=> tried to put IE as default web browser (some people explained the advertisement on Skype needed IE...) I'm asking myself if it's not another way to force us to use IE instead of any other browser? Hope not...

=> tried to uninstall, reinstall

=> tried to uncheck anything relating to ads on Skype options.

I have to use Skype web now...

1 person found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I'm on Win7 and this was killing me too on v7.37.0.103.  I just updated to the newer one (v7.38.0.101) and this fixed it.

Skype is now at 0% CPU and 130 MB RAM, whereas before it was 30% CPU and 130 MB RAM.

For future reference, this is a good place to find older versions of software - http://filehippo.com/download_skype/

EDIT: a few hours after updating to 7.38, the problem has already returned.  I'm going to try each earlier versions from 7.36 and backwards.

4 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Hi Theras,

The only working solution for Win7 I've found, is to put IE as web browser by default. You should be ok.

But it's not working on Windows 10.

The only thing that works for me on Windows 10 : using the Skype app for windows 10 natively. Not the skype for desktop.

But it's not the same at all... Hate that version.

If only the protocol allowed us to use it on another app as trillian, pidgin, etc...

3 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Yeah thanks.  I already had IE as my default browser when I was having the trouble on 7.37 and 7.38.

7.36 is behaving really well so far, though, which makes sense coz I've only noticed the problem recently so it was probably a recent update that hurt me.

2 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

After 3 days, v7.36 is working perfectly with mostly 0% CPU.  I believe this is a fix for WIn7.

2 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

7.0.38 on Windows 10 (1607).   Same CPU issue.   

1 person found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

 
 

Question Info


Last updated September 23, 2020 Views 18,789 Applies to: